Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

amanjain57
Contributor

Nprinting Reports not showing up in the QlikSense Hub

Hi,

I have installed NPrinting and connection setup was successful.

When creating reports, I can see the reports in the NewsStand but I could not find them in the QlikSense Hub.

Although i gave the right address to the Hub in Central Node Address.

Error4.JPG

The Central Node address is from the Qlik Sense Nodes- Host name

Error 5.JPG

But my Hub in Qlik Sense is not showing up the reports.

Also my users are not getting emails with the reports.

Any thoughts?

1 Solution

Accepted Solutions
amanjain57
Contributor

Re: Nprinting Reports not showing up in the QlikSense Hub

So, I upgraded to NPrinting 17.3 SR1.

That was a known Bug. The problem is solved now.

Thanks everyone for help.

36 Replies
ogster1974
Honored Contributor II

Re: Nprinting Reports not showing up in the QlikSense Hub

Have you checked the scheduler logs to see what's happening when you are publishing your task   this will indicate what's happening when you are trying to send reports to particular users.

amanjain57
Contributor

Re: Nprinting Reports not showing up in the QlikSense Hub

Andy,

Where can i check the scheduler log??

amanjain57
Contributor

Re: Nprinting Reports not showing up in the QlikSense Hub

Andy attached is the schduler log.

Seeing bunch of errors, but i don't know where to go from here?

ogster1974
Honored Contributor II

Re: Nprinting Reports not showing up in the QlikSense Hub

C:\programdata\nprinting\logs

And open the scheduler log your last publish task results should be at the bottom of the file.

amanjain57
Contributor

Re: Nprinting Reports not showing up in the QlikSense Hub

I have given permission to the user - Assigned him USER/Developer role.

But still the reports are not published in the hub.

Not sure what is the reason.

ogster1974
Honored Contributor II

Re: Nprinting Reports not showing up in the QlikSense Hub

Is he getting the email and not the hub or still both delivery options not working?

If it's a reports permissions issue try Going to admin/security roles and making sure that the user role is enabled.  I had a similar issue an I found that fixed it.

amanjain57
Contributor

Re: Nprinting Reports not showing up in the QlikSense Hub

he is not getting email, nor the hub is publishing report

in admin roles, user role is also enabled

ogster1974
Honored Contributor II

Re: Nprinting Reports not showing up in the QlikSense Hub

Is he the only user not getting the report or is the report failing full stop? Have you been able to send reports to this user before?

The enabling of user role (not sure why if as disabled) fixed my issue with it so not sure what else to suggest. The fact it's all delivery options points to it being a user permissions issue.

gpr
Contributor III

Re: Nprinting Reports not showing up in the QlikSense Hub

Hi,

from the logfile I see some errors:

1) Unable to send e-mail for bucket 1abc7da5-b95e-4daa-ac1b-6b848dd4ce08 because the smtp configuration is null

This means that smtp server configuration is missing

2) The user Brandon.Dudley for the task Booking Billing report has no permission to see the published reports.

This means that the recipient Brandon Dudley has not the right permission to see the reports (NewsstandUser)

3) Cannot publish to Sense Hub: The remote server returned an error: (400) Bad Request.

This probably means that the Sense certificates are not installed into the NPrinting Server machine.

Could you please verify these configurations and see if something is missing?

Thanks

Community Browser