Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

sujeet_shirude
Contributor II

Nprinting: User receives email but no report attachment

Hi all,

We have Nprinting June 2017 version. One our users receives the Nprinting email but does not receive the attachment.

In his email it gives the error: "Some errors occurred during report generation Number of reports not generated: 1 Please contact your administrator for further details".

The same attachment/report is delivered successfully to other 17 users. As far as I can tell he is set up in  exactly the same way as all the other users in the group. There are no user level filters. Attached is the error I see in the "Task Executions".

Any insights on the same are appreciated.

djk

Thank you,

Sujeet Shirude.

1 Solution

Accepted Solutions
sujeet_shirude
Contributor II

Re: Nprinting: User receives email but no report attachment

Thanks all!

In the Connections- we had section access enabled. Once I disabled it, the user received the attachment. Section_Access.PNG

20 Replies
Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting: User receives email but no report attachment

i would troubleshoot this by sending report also to folders destination to see whether they are landing there at all. I understand that there is no section access on source documents and all users should see the same thing? right?

regards

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.

Re: Nprinting: User receives email but no report attachment

If its one specific user facing this issue then check the email setting of that user and privileges  that has set for him

neha_shirsath
Valued Contributor

Re: Nprinting: User receives email but no report attachment

In order to be a NPrinting report recipient user needs to have a role in NPrinting. Make sure this user have at least "Users" or "NewsStand User" or have any other role which allows them to receive reports.

Lech_Miszkiewicz
Honored Contributor III

Re: Nprinting: User receives email but no report attachment

Guys - you are touching different subject! Examples you are talking about will not send email at all!

The problem mentioned above is that attachment is not going together with email to only one user - which is different behaviour.

regards

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
Employee
Employee

Re: Nprinting: User receives email but no report attachment

Check that the object bnzfCP still exists in the Qlik Sense app you are using as data source.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
sujeet_shirude
Contributor II

Re: Nprinting: User receives email but no report attachment

Thanks for your response Lech!

Right, there is no section access on source documents.


I checked the Newstand and the report does exist.

sujeet_shirude
Contributor II

Re: Nprinting: User receives email but no report attachment

Thanks, Avinash!

I checked email setting & privileges for the user and its the same as the remaining users. I even deleted and re-created the user.

sujeet_shirude
Contributor II

Re: Nprinting: User receives email but no report attachment

Thanks, Neha! Yes, the user has both the roles.

sujeet_shirude
Contributor II

Re: Nprinting: User receives email but no report attachment

Yup, exactly.

Community Browser