Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

srinivas1921
New Contributor III

Nprinting on demand is not working for one user

Hi all, We have developed ondemand functionality in our qlikview app and it is working fine as expected for everyone. . But one user faceing problem with ondemand. Whenever he click on NP report button  there is no action found from NP queue button from his side. Please suggest what was the possible reasons to not working on demand functionality for him.

1 Solution

Accepted Solutions
Employee
Employee

Re: Nprinting on demand is not working for one user

Hi Srinivas,

Have the On-demand extension objects been installed on that user's machine?

If so, can you try this:

* Open the On-demand extension object properties and note the  details

* on the machine where it is not working, enter in a web-browser address bar http://<Hostname>:9001/help (replace Hostname with the contents of the Hostname field noted in the previous point. Also change to https if SSL is used).

* You should get something like the below

If not, you will need to investigate why. Probably a firewall (port needs to be opened) or DNS issue (try Telnet and/or nslookup) etc.

HTH - Daniel.

2 Replies
Employee
Employee

Re: Nprinting on demand is not working for one user

Hi Srinivas,

Have the On-demand extension objects been installed on that user's machine?

If so, can you try this:

* Open the On-demand extension object properties and note the  details

* on the machine where it is not working, enter in a web-browser address bar http://<Hostname>:9001/help (replace Hostname with the contents of the Hostname field noted in the previous point. Also change to https if SSL is used).

* You should get something like the below

If not, you will need to investigate why. Probably a firewall (port needs to be opened) or DNS issue (try Telnet and/or nslookup) etc.

HTH - Daniel.

srinivas1921
New Contributor III

Re: Nprinting on demand is not working for one user

Thanks Daniel for your great support... we have found that user unable to get the message something like above.So there is no access to that particular server from his machine and also suggested him to take help from their Network team to investigate on this.

Community Browser