Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Uploads getting stuck in the virus scanner. We are investigating.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Creator
Creator

Nprinting seems to strip HTML 5 tags - is this expected behaviour?

Using 17.6 I notice that HTML 5 tags are not copied to the output:

<BR>
<details>
<summary>Example</summary>
<p>
%%CH80%%
</p></details>

produces a collapsible section in the preview but not in an email report. Is this expected behaviour?

Thanks

 

 

Labels (1)
2 Solutions

Accepted Solutions
Highlighted

If you are talking just about html file as an output to ZIP file, everything from template should be there...

Story looks diferently when you talk about html embeded in email body...

 

so what is your original  template like? can you share?

If you are talking about embeded html report in email body, then i think everything between <Body> tags will be moved to email, however as email clients do not support <SCRIPT> tags, those will not work in your emails.. 

 

cheers

Lech

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

Highlighted
Employee
Employee

Hi,

I just tested your HTML code with latest version (February 2019) and:

- the zipped HTML sent as email attachment contains the all the code and works fine

- if you embed the same HTML report in the email body part of the code is removed, but it is present in the attachment so it is the email client who removes the code.

So I suggest you to update your installation to solve the issue.

Best Regards,

Ruggero 



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

3 Replies
Highlighted

If you are talking just about html file as an output to ZIP file, everything from template should be there...

Story looks diferently when you talk about html embeded in email body...

 

so what is your original  template like? can you share?

If you are talking about embeded html report in email body, then i think everything between <Body> tags will be moved to email, however as email clients do not support <SCRIPT> tags, those will not work in your emails.. 

 

cheers

Lech

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

Highlighted
Employee
Employee

Hi,

I just tested your HTML code with latest version (February 2019) and:

- the zipped HTML sent as email attachment contains the all the code and works fine

- if you embed the same HTML report in the email body part of the code is removed, but it is present in the attachment so it is the email client who removes the code.

So I suggest you to update your installation to solve the issue.

Best Regards,

Ruggero 



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

Highlighted
Creator
Creator

Ruggero  Thanks - I am using an embedded HTML report so it is MS Outlook that is the issue, not NPrinting. Regards Nick