Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

bobbydave
Contributor II

Object not appearing in nPrinting

So I have an application and all appears fine.

However, all but one object will appear when imported into nPrinting.

I've even recreated the chart as a table also.

if I leave the tag cells on to show the columns, it shows the tag cells but otherwise, will not show the data below.

Anyone come across this.

Its only the one chart. Every other chart appears.

Help appreciated

1 Solution

Accepted Solutions
Not applicable

Re: Object not appearing in nPrinting

I made a new connection to "scorecard.qvw"

I made a new Excel report

I added CH24 as both a table and an image.

I added them to the report and previewed.

It seems to be working correctly to me.

Not sure why you're having issues

NB this is a pivot table, so you won't be able to do too much in terms of formatting and you won't have any control over which dimensions are included (they will all be included).

screenshot.PNG

5 Replies
Not applicable

Re: Object not appearing in nPrinting

  1. Try saving everything (QVW and NPrinting NSQ file) closing both applications and trying again.
  2. Is the chart hidden or in a container; objects in containers in other containers cannot be used?
  3. Is the chart an extension object (these are not supported)?
  4. If you can share the NSQ, QVW and template files and/or some screen shots of the template and QVW that would be very helpful
bobbydave
Contributor II

Re: Object not appearing in nPrinting

Hi Aran,

Attached is the nsq. Its tab Appendix C which is the issue (the second half of the screen; top half works)

I've also attached the QVW.

I am trying to attach the Historic (I've eliminated other data that was originally on the qvw as its confidential).

Any help appreciated

Not applicable

Re: Object not appearing in nPrinting

I made a new connection to "scorecard.qvw"

I made a new Excel report

I added CH24 as both a table and an image.

I added them to the report and previewed.

It seems to be working correctly to me.

Not sure why you're having issues

NB this is a pivot table, so you won't be able to do too much in terms of formatting and you won't have any control over which dimensions are included (they will all be included).

screenshot.PNG

Not applicable

Re: Object not appearing in nPrinting

rebuild the connection, verify you have the correct connection selected if you have multiple connections in the nsq.

If the object in question was added after the connection was created, a refresh at the connection may be requred

bobbydave
Contributor II

Re: Object not appearing in nPrinting

I ended up creating a new template.

I think I remember my other template crashing at one stage and after that, I started running into difficulty. I am wondering if this lead to my issue.

Either way, resolved now with a new template.

Thanks

Community Browser