Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
kdmarkee
Specialist
Specialist

On Demand button missing from Access Point - NPrinting 17

I'm wondering if anyone can give me some hints as to why I cannot see the On Demand button in my qvw app on Access Point.  I have all the following in place:

  • I have QV 12.10 SR 6 with NP 17.3.0.0
  • On Demand add-on was installed on the QV server
  • my NP service account user is a member of both the QlikView Administrators and QlikView Management API groups on the QV server
  • I have a successful server connection established (metadata has been generated) in the NP web console between NP and my QV app
  • I have the 2 server paths we use to connect to our Access Point added to the trusted origin list in NP web console
  • I have a NP report set up to use the correct app and connection within the NP web console, and have On Demand enabled within that report
  • I have myself listed as a user in the NP web console with admin role, with both my Active Directory domain account listed and On Demand rights enabled
  • I am using Chrome for launching Access Point and the NP web console

Thanks in advance for the help.

1 Solution

Accepted Solutions
sfatoux72
Partner
Partner

Hi,

The problem is on QlikView server, you must add the missing mime types to make the On-Demand add-on work.

Add the two new mime types in the QMC:

In the QMC, open the System tab.

  1. Click Setup.
  2. Expand the QlikView Web Server node.
  3. Click on QVWS@YourServer.
  4. Click the Web tab.
  5. In the Mime Types section, the click the green + button in the upper right corner.
  6. Add the following rows:
    • .JSON in the Extension column and application/json in the Content column
    • .TTF in the Extension column and application/x-font-truetype in the Content column

Clik Ok to validate, and it will work

View solution in original post

7 Replies
Frank_S
Support
Support

See Known Limitations section of NP 17.3 SR 1 releases notes for solution.

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
sfatoux72
Partner
Partner

Hi,

The problem is on QlikView server, you must add the missing mime types to make the On-Demand add-on work.

Add the two new mime types in the QMC:

In the QMC, open the System tab.

  1. Click Setup.
  2. Expand the QlikView Web Server node.
  3. Click on QVWS@YourServer.
  4. Click the Web tab.
  5. In the Mime Types section, the click the green + button in the upper right corner.
  6. Add the following rows:
    • .JSON in the Extension column and application/json in the Content column
    • .TTF in the Extension column and application/x-font-truetype in the Content column

Clik Ok to validate, and it will work

View solution in original post

kdmarkee
Specialist
Specialist
Author

Thanks.  I added the 2 items, but there must be something else I'm missing or have done incorrectly as the On Demand button still did not appear.

kdmarkee
Specialist
Specialist
Author

Another related question...is the QlikView Management API group a new group that would have been added during the On Demand add-on install process or was that part of the NPrinting install process?  (I didn't actually do the installs which is why I ask; I'm wondering because I see the info about rebooting the QV and NP servers when the NP service account user is added to this group)

sfatoux72
Partner
Partner

‌Have you restart the QlikView services?

The button is only available in Ajax mode, not with IE plugin

Lech_Miszkiewicz

Hi Kris


RE QlikView Management API group for OnDemand and other setups tricks :


1. The domain account used for the NPrinting service must be a member of:

  • Administrators group
  • QlikView Administrators group
  • QlikView Management API group

This group must be created manually and the service account added to the group

Following this step, restart both the QlikView and NPrinting services


2. When installing OnDemand add-on:

  • the install will ask for the URL of the NPrinting server. Be sure that there is not a slash following the port number. This will cause the connection to the NPrinting server to fail.
  • If the NPrinting Server and NPrinting Engine are installed on different machines, make sure to use the Server URL.


3. Add the QlikView Server as a trusted origin in NPrinting Console


cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
kdmarkee
Specialist
Specialist
Author

As a last ditch effort we did in fact just restart QV this morning and the button appeared, thanks.  But when we select it, it is telling us it cannot find a connection, but we did find that the url had a slash in it and once changed it worked.  In addition to that, we also discovered that we think we have to install the On Demand add-on on our extranet server as well because we have 2 ways to get to our Access Point and right now we only see the button via one of the ways and not the other.  So I have more research/troubleshooting to do, I guess.