Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

bobbydave
Contributor III

On Demand buttons not appearing on Chrome IE or Firefox

I have 2 servers,

  • a development server where my app lies
  • and a  dedicated nPrinting server

I have On Demand functionality working on my development server which reaches out to the nPrinting server to call the nsq to create the reports with the On Demand object buttons. That is all good.

Now ... what i am trying to achieve is to get this now to appear on IE, Chrome or Firefox.

I cannot see the buttons appearing.

I have nPrinting server 16 SR 5 installed.

I cannot upgrade to 17.X just yet as it requires approvals etc.

Anyone any help on why i cannot see the buttons appear on any browsers through Access Point.

Thanks

1 Solution

Accepted Solutions
hopkinsc
Valued Contributor II

Re: On Demand buttons not appearing on Chrome IE or Firefox

Sorry David,  is the accesspoint (QVWS) on the Dev server or a different server?

13 Replies

Re: On Demand buttons not appearing on Chrome IE or Firefox

Have you installed the Extension in the server ??

and also check you have checked the 'Allow extensions' option in the Qlik Server (System --> Setup --> Security)

hopkinsc
Valued Contributor II

Re: On Demand buttons not appearing on Chrome IE or Firefox

so you have it working using the QV client in web view mode? is that what you're saying?

and now you want to get it working in the browser on the same server?

bobbydave
Contributor III

Re: On Demand buttons not appearing on Chrome IE or Firefox

Yes, I removed the option for the server but allowed the install of the Extensions to be installed.

Under security, i have 'Allow Extensions' ticked.

I have On Demand working on the application itself. And the reports do run correctly.

It is when i go to browse it on the web (in Access Point), that i cannot see the buttons that were created using the Extension Objects.

bobbydave
Contributor III

Re: On Demand buttons not appearing on Chrome IE or Firefox

Exactly. It works on my development server.

But it is when i try to go to Access Point, I can see regular buttons that I created for the app but no On Demand buttons.

hopkinsc
Valued Contributor II

Re: On Demand buttons not appearing on Chrome IE or Firefox

are the extension objects installed for all users and not just the user you are logged on as on the dev server?

i guess when you're on the accesspoint, where the on demand button should be it says something like object unavailable (i cant remember the actual message)?

bobbydave
Contributor III

Re: On Demand buttons not appearing on Chrome IE or Firefox

No message appears at all.

Nothing is visible, On Demand related.

I can see two buttons that are Qlikview buttons and the functionality all works as is but just cannot see the On Demand buttons.

bobbydave
Contributor III

Re: On Demand buttons not appearing on Chrome IE or Firefox

On any browser.

Internet Explorer, Chrome or Firefox

hopkinsc
Valued Contributor II

Re: On Demand buttons not appearing on Chrome IE or Firefox

Sorry David,  is the accesspoint (QVWS) on the Dev server or a different server?

bobbydave
Contributor III

Re: On Demand buttons not appearing on Chrome IE or Firefox

Hi Chris.

As an end user, I should be able to go onto Access Point (http://myServer/Qlikview) and once in here, click on my app and it should be visble with the On Demand buttons?

Community Browser