Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

cancel
Showing results for 
Search instead for 
Did you mean: 
vitaliichupryna
Creator III
Creator III

Pixel Perfect - Data not visible

Hi,

I've created report with few levels, in general it works fine, but I can't fix one bug. 

When data in the Measure 1 or 2 is 0 in the Qlik. Nprinting shows empty space instead of data.

I don't understand why it's happened and how to fix it, I tried add text function :text(Sum(Measure1)), but still have the same result

 

Qlik    
Level    
SubLevelMeasure1Measure2Measure3Measure4
A1112
B0033
C0046
D3142
     
Report    
Level    
SubLevelMeasure1Measure2Measure3Measure4
A0012
     
     
D3142
Labels (2)
1 Solution

Accepted Solutions
Ruggero_Piccoli
Employee
Employee

Hi,

Thanks. In the Detail7 band you inserted the first field Attrition_BUname_1 but it is not visible in the BD/BU table. Where that field come from? Maybe you have to replace it with the Attrition_BUname field that appears in the table.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

5 Replies
Ruggero_Piccoli
Employee
Employee

Hi,

Could you post some screenshots of the template? I think you added the wrong entity in the Levels node. You have to add the same straight table used in the level details band. In the entity added in the Levels node those rows are present, but they are not in the entity inserted in the details band. 

Another alternative is to apply a formatting rule to hide rows with no data to the detail band. 

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
vitaliichupryna
Creator III
Creator III
Author

 

Hi Ruggero,

In the qliksense I see data, data isn't visible in the report.

On the top level I use field BDName and then on the second level I use straight table.

I tried to use straight table on the top and second level, but in this case I can't generate report

Issue.jpg

Issue2.jpg

Ruggero_Piccoli
Employee
Employee

Hi,

Thanks. In the Detail7 band you inserted the first field Attrition_BUname_1 but it is not visible in the BD/BU table. Where that field come from? Maybe you have to replace it with the Attrition_BUname field that appears in the table.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

vitaliichupryna
Creator III
Creator III
Author

Hi,

Attrition_BUName_1 is comming from table tVPFQ - BD/BU for this reason it's not visible in the level. 

I changed template and started to use columns from level and  it shows all the data. I'm a little bit confused because based on the tutorials we should add table and use table in the Detail part.

Ruggero - thank you for help!  

 

Thanks,

Vitalii

 

Issue3.jpg

Lech_Miszkiewicz

https://help.qlik.com/en-US/nprinting/November2019/Content/NPrinting/PixelPerfectReports/Simple-PP-R...

Official help tutorial seem to use fields from level. @vitaliichupryna  what tutorial are  you using?

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.