Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Jjotavve
Contributor II
Contributor II

Pixel Perfect custom summaries disappear in September 2020 version

Hello,

I am in the process of migrating a lot of NPrinting reports from 16.9.0.0 (SR9) to September 2020. I export my nsqs as zip files and use the import tool in NPrinting September 2020. It is going pretty well but I have this particular issue which is giving me a headache.

 

I have three PixelPerfect reports with custom summaries all following the same pattern of custom rules, like this one:

Private PlannedTurnoverGroup as Double
Private TurnoverGroup as Double

Private Sub PlannedFulfillmentGroup_SummaryGetResult(ByVal sender As Object, ByVal e As DevExpress.XtraReports.UI.SummaryGetResultEventArgs)
e.Result = TurnoverGroup/PlannedTurnoverGroup
e.Handled = True
End Sub

Private Sub PlannedFulfillmentGroup_SummaryReset(ByVal sender As Object, ByVal e As System.EventArgs)
PlannedTurnoverGroup = 0
TurnoverGroup = 0
End Sub

Private Sub PlannedFulfillmentGroup_SummaryRowChanged(ByVal sender As Object, ByVal e As System.EventArgs)
	TurnoverGroup += Convert.ToDouble(SRep.GetCurrentColumnValue("Turnover M"))
	PlannedTurnoverGroup += Convert.ToDouble(SRep.GetCurrentColumnValue("Planned Turnover Month N"))
End Sub

 

These custom summaries work fine in version 16 but in September 2020, my cells are empty and I've been trying to understand why for the last couple of hours with no success. I was not able to spot any difference between the two reports. I also couldn't find any topic related to this particular issue, unfortunately.

Was anybody confronted to the same issue?

 

Labels (2)
1 Solution

Accepted Solutions
Ruggero_Piccoli
Support
Support

Hi,

Starting from February 2020 you must enable the execution of PixelPerfect scripts that is disabled by default. 
Go to Admin -> Settings -> Report -> PixelPerfect security and enable the flag "Enable script execution". Refer to https://help.qlik.com/en-US/nprinting/November2020/Content/NPrinting/AdministeringQVNprinting/Admin-... and February 202 Release Notes.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

4 Replies
Ruggero_Piccoli
Support
Support

Hi,

Starting from February 2020 you must enable the execution of PixelPerfect scripts that is disabled by default. 
Go to Admin -> Settings -> Report -> PixelPerfect security and enable the flag "Enable script execution". Refer to https://help.qlik.com/en-US/nprinting/November2020/Content/NPrinting/AdministeringQVNprinting/Admin-... and February 202 Release Notes.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Frank_S
Support
Support

Thank you @Ruggero_Piccoli 

This information has been consequently been added to the NPrinting Migration Playbook as well.

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Jjotavve
Contributor II
Contributor II
Author

Thank you @Ruggero_Piccoli. I went to the Admin section and apparently completely skipped this part earlier today, sorry.

 

Ruggero_Piccoli
Support
Support

You are welcome. Good to read that you solved!

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.