Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Preview Error - Failed to Render

 am trying to preview an Excel template based on a Qlik Sense app and I'm getting the following error:

nPrinting Error.jpg

The object in question is a KPI and I have tried five different KPI objects and all are failing to render.  This is with a new app, connection and report.  

Labels (2)
4 Solutions

Accepted Solutions
Highlighted
Support
Support

If you have chart suggestions enabled, this could be causing the issue.

See the following article around troubleshooting image issues such as this which I posted earlier this year.

https://support.qlik.com/articles/000056332

If this or the other points in the article do not resolve the issue, then I suggest starting a support case so that your issue can be investigated in greater detail.

disable chart suggestions.PNG

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Highlighted
Employee
Employee

Hi,

Please always specify the version of the software you are using. If you are not updated to latest version I always suggest to start by upgrading Qlik NPrinting to benefit of all bug fixes. Be sure also to refresh the connection cache.

Check that all objects used in the template are still available in the connected app or document by using the Check Entities feature.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

Highlighted
Partner
Partner

Sadly, no.  Worked directly with support.  Tried exporting the app I was using and then importing it again and that helped for a few days before the error reappeared.  This was in one of our test environments  and when we installed NPrinting into our standard Dev environment the issue has not reappeared.  Both installs were using the Nov 2018 release. 

The only thing that changed besides the environment is we rolled back from Nov 2018 Qlik Sense to the April 2018 version.

View solution in original post

Highlighted
Support
Support

We recently discovered (Friday May 3rd) that some customers are experiencing certificate mismatches between the NPrinting server and the Qlik Sense server.

The solution is to re-export your certificates from the Qlik Sense server and re-import them to NPrinting.

For more information regarding detailed fix instructions, see the following article:

https://support.qlik.com/articles/000073482

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

10 Replies
Highlighted
Partner
Partner

I just tried closing it all down and then reloading the metadata in the connection and I'm still getting this error.

Highlighted
Support
Support

Are you able to view the object hjnSFn when logged into the QS hub?

You can check your objects health using the Single Configurator tool as shown below:

If the object is valid here then it should be working for NPrinting reports. If not then there is a problem with your QS object hjnSFn. If this object is corrupted you may need to rebuild it.

Also check the following regarding preparing QS objects to work with NP.

https://help.qlik.com/en-US/nprinting/April2018/Content/ReportsDevelopment/Qlik-objects-supported-NP...

 

single configurator in dev hub.PNG

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Highlighted
Partner
Partner

The object works fine in both the Hub and the Single Configurator.  It is a KPI object being pulled into the template as an Image.

Highlighted
Support
Support

If you have chart suggestions enabled, this could be causing the issue.

See the following article around troubleshooting image issues such as this which I posted earlier this year.

https://support.qlik.com/articles/000056332

If this or the other points in the article do not resolve the issue, then I suggest starting a support case so that your issue can be investigated in greater detail.

disable chart suggestions.PNG

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Highlighted
Partner
Partner

Chart suggestions were never enabled.  Will be opening a ticket.

Highlighted
Partner
Partner

Hi, 

Do you have an update on this? 
Have the same problem and would like to know if you/the support found a solution. 

 

Kind regards

Highlighted
Employee
Employee

Hi,

Please always specify the version of the software you are using. If you are not updated to latest version I always suggest to start by upgrading Qlik NPrinting to benefit of all bug fixes. Be sure also to refresh the connection cache.

Check that all objects used in the template are still available in the connected app or document by using the Check Entities feature.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

Highlighted
Partner
Partner

Sadly, no.  Worked directly with support.  Tried exporting the app I was using and then importing it again and that helped for a few days before the error reappeared.  This was in one of our test environments  and when we installed NPrinting into our standard Dev environment the issue has not reappeared.  Both installs were using the Nov 2018 release. 

The only thing that changed besides the environment is we rolled back from Nov 2018 Qlik Sense to the April 2018 version.

View solution in original post

Highlighted
Partner
Partner

Okay - Thanks for the update.