Qlik Community

Ask a Question

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
jleraille
Partner
Partner

Qlik.NPrinting.Repo.Service.LicenseService : licence violation

Hello
I installed NPrinting 2019 SR1 (Server, Engine, Designer) on windows server 2016

-With the user NPadmin (admin role)
-Engine is online
-I checked that the NPrinting license is activated
I created an app and created a connection with OK verification
The Server Connection Stuck On "Generating" and in the nprinting_webengine.log file there is Fatal errror "Qlik.NPrinting.Repo.Service.LicenseService ...... The number of USERS exeed the current license limit (1 found, but 0 allowed)"

I note that there is no usename information for the concerned line. (see the attached file)

Do you have a track to go through this step?
Thanks

1 Solution

Accepted Solutions
jleraille
Partner
Partner
Author

Qlik support identified the problem.

NPrinting requirements system needs at least 2 cores.  (It is in the help file...)

My PC is a 4 core but I created a Windows server VM and I did'nt pay attention that default creation was done with 1 core
I recreated my VM with 2 cores, reinstalled NPrinting and actually the connection is ok

Thanks to all

View solution in original post

23 Replies
Lech_Miszkiewicz

is this a connection to QlikView document or Qlik Sense document.

If QlikView - it is likely you have not leased USER CAL license to QlikView desktop instance for NPrinting service account user which is required on machine where NPrinitng engine is installed.

regards

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Lech_Miszkiewicz

I actually looked at your logs and i think your issue is not related to license..

It would be good if you could attach all logs, especially engine and scheduler. 

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
jleraille
Partner
Partner
Author

Hello Lech

Thank you for your attention.
I work with Qlikview v12 sr2
Yes I have attached the desktop license to NPadmin (user NPprinting)

Find the log

Thank you a lot

Lech_Miszkiewicz

looks like you are putting through path to your Qlik Document wrong:

C:\NPrintingServer\QV Documents\Exemples\sales_demo.qvw";qlikviewversion=12.10.20000 failed. System.IO.FileNotFoundException: Connection string document not found: C:\NPrintingServer\QV Documents\Exemples\sales_demo.qvw.

Do you have "Examples" or "Exemples"?

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Lech_Miszkiewicz

by the way

can you screenshot your connection "verification" result screenshot?

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
jleraille
Partner
Partner
Author

Lech

See my vérification screen shot,
But I'm surprised because i named this connection Sales_Demo  thinking it might be the space that posed problem.

And in the log message there is  "Sales_Demo.qvw" instead of "Sales Demo.qvw" ?

Lech_Miszkiewicz

Try looking what happens with QV when previewing session 0

https://community.qlik.com/t5/Qlik-NPrinting-Discussions/Cache-Generation-Failed-On-Specific-Model/t...

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
jleraille
Partner
Partner
Author

Lech

I suppressed my connection

I tried your recommandation :
I added the registry key
I executed commands  sc.exe config ui0detect start= auto   and     sc.exe start ui0detect

I created the new connection but there is no change, "générating" always blinking

Frank_S
Support
Support

Hi

Lech is correct, the license log error is not the issue. That error shows cleared later in your logging.

The problem appears to be the invalid path to your QVW as per your logs.

System.IO.FileNotFoundException: Connection string document not found: C:\NPrintingServer\QV Documents\Exemples\sales_demo.qvw

You must ensure that the path specified is a valid path on your NPrinting server. So either:

  • The path is invalid or the file name is invalid causing the invalid path error message in your log.
  • The NP service account is unable to open the QVW on the NP server

Next:

  • Log onto the NP server using the NP service account
  • Open the path that is indicated above and repair the path and or the name of the QVW.

Note that the NP service account must have a valid QV user CAL assigned. See the following article for more information. https://support.qlik.com/articles/000033911

That should do it.

Hope this helps...

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!