Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Not applicable

Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Hi all,

I'm (trying to) evaluate Qlik Nprinting. I've got a Qlik Sense production server (3.2.0) running since a long time, and a few days ago I followed the following guide to set up Qlik Nprinting (17.3):  Installing Qlik NPrinting ‒ Qlik NPrinting

All services are working fine, and I followed Creating connections ‒ Qlik NPrinting to connect to my Sense app, created by the same account as I've setup and created everything in Nprinting with. I've exported the certificates from my Sense server and installed them, using the "QmcCertificatesInstaller". There's no firewall between the two servers, and I've disabled the Windows Firewall just to make sure none of my rules are messed up.

The Qlik Sense app I'm trying to get the Qlik Nprinting Connection to work against is based on a 100kb .csv, and consist of a single pie chart. I've been waiting for 3 days for the Qlik Nprinting Connection Cache to finish. I've restarted all the services, and the server several times and recreated the Connection.

I've reinstalled Qlik Nprinting and made sure I followed the guides fully. Since the Cache status is stuck on "Generating", no errors are logged anywhere in "C:\ProgramData\NPrinting\Logs". The latest entry in the logs are:

nprinting_webengine.txt: "

Qlik.NPrinting.Repo17.3.0.0Qlik.NPrinting.Repo.Service.DataConnectionService20170509T110952.816+02:00INFONPRINTINGLABNprintingService009cabf2ac-b5c0-4ad5-a18b-e8a8d82c129db8eb3144-6835-4f11-82b0-a626f10abf3e0000Reload metadata task b8eb3144-6835-4f11-82b0-a626f10abf3e sent to queue

"

nprinting_engine: "

Qlik.NPrinting.Engine17.3.0.0Qlik.NPrinting.Engine.EngineService20170509T101202.180+02:00INFONPRINTINGLAB00000000Slave Engine Service started successfully

"

The engine is running according to Admin > Engine manager

I'm running out of both ideas and time, hopefully there's a helpful soul out there!

I guess the final thing I can mention is that both the Sense and Nprinting server is running Windows Server 2016, I guess that's not too common yet.


Best regards,
Melker

1 Solution

Accepted Solutions
Lech_Miszkiewicz
Honored Contributor III

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

also - regarding restart & connection

once connection task was started with wrond parameters it wasn't killed and it was in "stale" mode.

restart killed the old stale one and started new one with the correct settings.

cheers

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
12 Replies
Lech_Miszkiewicz
Honored Contributor III

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Hi,

Couple o things:

  • NPrinting account - did you allocate license/token to NPrinting service account in QlikSense QMC?
  • Could you attach screenshot of your connection page ( so can see how you type in proxy and app id and Identity field
  • could you RDP to NPrinting server using NPrinting account and open QlikSense Hub and the open desired application (take then a snapshot of whole screen - especialy url address)  - this is to ensure that app is not sitting in "somebody elses" work folder and can be actually accessed by NPrinting service account

Once you are done with above we will take it from there

cheers

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
Not applicable

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Yes, license/token is allocated. I've created the app in Qlik sense using the NPrintingService account.

qlikNprintingConnectionScreenshot.PNG

And here's the app in Sense, using the same account:

qliksenseapp.PNG

Lech_Miszkiewicz
Honored Contributor III

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Have you implemented Secction access in qlik sense document? In your connection you have that "checked"

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
Not applicable

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Sorry - no. I've tried without that checkbox before with the same result. I've unchecked it again now (and hit Reload), 15 minutes later still nothing.

Lech_Miszkiewicz
Honored Contributor III

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Are you able to restart NPrinting server (BOX)?

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
Lech_Miszkiewicz
Honored Contributor III

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Did you follow this quide as well?

http://help.qlik.com/en-US/nprinting/17.3/Content/DeployingQVNprinting/Sense-requirements.htm

In the QMC, you must assign RootAdmin authorization to the Windows user that runs the Qlik NPrinting EngineWindows service. That Windows user must also be a domain user.

The following firewall rules must be created to allow connections:

  • Ports 4242 and 4243 must be opened inbound on the Qlik Sense server computer (the computer where Qlik SenseRepository Service (QRS) and Qlik SenseProxy Service (QPS) are installed).
  • Ports 4242 and 4243 must be opened outbound on Qlik NPrinting Server and Qlik NPrinting Engines.
  • Port 4747 must be opened inbound on the computer where Qlik SenseEngine Service (QES) is installed.
  • Port 4747 must be opened outbound on Qlik NPrinting Engines.

Additional user access allocation in Qlik Sense is not required for a user to view reports in the Qlik Sense hub.

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
Not applicable

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

Restarting the NPrinting server as we speak - and yes, the user is a domain user, and is Root Admin on the sense server. There's no firewall between the servers.

Not applicable

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

God damnit, I've must have done something else in between having the checkbox checked and not checked. It generated after reboot! The designer doesn't seem to work, but I'll start a new thread for that if I can't get it to work. Thank you so much for your time Lech!
invalidlength.PNG

Br,
Melker

Lech_Miszkiewicz
Honored Contributor III

Re: Qlik Nprinting connection to Qlik Sense - Cache status stuck on "Generating"

One problem solved

now - what version of NPrinting are you using?

Since you are configuring it now i suggest to update to 17.3.1.

If you have a server running 17.3.1 that is good, but your designer version is 17.2.1.0 - start with an upgrade.

Are you installing designer on your laptop? or on server? It is recomended to have it on laptop.

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
Community Browser