Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Qlik Analytics Tour 2020 Online. Begins August 10th. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Report failed in newsstand after adding filters

I published a report to the newsstand and worked fine. Afterwards I added some filters to the report it just fails when publishing it to the newsstand. Any ideas why?

Tags (2)
1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Re: Report failed in newsstand after adding filters

What version are you using? 

The logs should state if anything was wrong, my guess is that it couldn't apply the filters.

View solution in original post

7 Replies
Highlighted
Partner
Partner

Re: Report failed in newsstand after adding filters

What version are you using? 

The logs should state if anything was wrong, my guess is that it couldn't apply the filters.

View solution in original post

Highlighted
Partner
Partner

Re: Report failed in newsstand after adding filters

Ok, that was a good hint. So I removed  one filter, which could have caused trouble. But this solved only half of my problem:

- Good news: the report gets published, preview available

- Bad news: the filter doesn't get applied.

 

I'm using this:

Qlik NPrinting September 2018

Version: 18.29.7.0

Filters should work... is there any reason why they shouldn't? I've set only one static Filter: Year = 2018, Year is a field, 2018 is a valid value... But the values in the reports don't get filtered. This is where I defined the filter:Nprinting_issue.PNG

Highlighted
Employee
Employee

Re: Report failed in newsstand after adding filters

Hi,

Please:

- check and post a readable screenshot of the Task Executions page. There could be a meaningful error message

- check and share the complete log files with the error message during the report creation

- the filters must be valid. Remove and add them again one by one to understand if it it a specific filter that generate the error

 

Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

 



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Partner
Partner

Re: Report failed in newsstand after adding filters

Do you mean this, when you say task execution page:

NPrinting_tasks.PNG

It just says the tasks were successfully executed. But the filter doesn't get applied. Were do I find the log files of NPrinting? I'm really new to it.

Highlighted
Partner
Partner

Re: Report failed in newsstand after adding filters

No, if you click on 'Admin' and 'Task Executions' it will list all of the tasks that have run. Click on the task name of the task that is failing and a log should appear giving you the reason of the failure. 

 

 

 

Highlighted
Partner
Partner

Re: Report failed in newsstand after adding filters

Yes, I found that! My original problem is now fixed. It was indeed the bad filter causing error. Thank you!

The issue with the filter not getting applied doesn't seem to be related to my previous problem, that the report didn't get published. It also doesn't generate any error. If I don't fix it, I will open another issue for it. The hint with the log file was very useful, thank you.

Highlighted
Employee
Employee

Re: Report failed in newsstand after adding filters

Hi,

Nice to ear that you solved.

If you are new to Qlik NPrinting the best place to start is the online help https://help.qlik.com/en-US/nprinting/November2018/Content/NPrinting/Introduction/Introduction.htm:

- Task executions page is explained here https://help.qlik.com/en-US/nprinting/November2018/Content/NPrinting/AdministeringQVNprinting/Monito...

- Logs are here https://help.qlik.com/en-US/nprinting/November2018/Content/NPrinting/AdministeringQVNprinting/Loggin...

 

Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.