Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

yubin_yu
New Contributor

SMTP Server to test sending emails failed, NPrinting 17.6

Hello all,

I have configured my SMTP server and unencrypted .

I get the following error when I try to email a report in NPrinting 17.6

Failed to send e-mail message to qv@michors.com. ERROR: The SMTP server does not support authentication.

The same SMTP configuration is successful on older versions,

But the same version is successful with other SMTP server on the virtual machine,

Because of other limitations, we succeeded in using other SMTP configurations on another virtual machine

How to solve this issue please?The detailed log is in the attachment

!

4 Replies
mauricio_marin
New Contributor

Re: SMTP Server to test sending emails failed, NPrinting 17.6

Hello all,

I have the same problem.

The SMTP server is configured on a IBM machine, it works well in older versions, but when i upgrade to NPrinting 17.6 it stoped working.

Someone know whats happening?

Have someone found how to solve the problem?

lakshmanshiv
New Contributor

Re: SMTP Server to test sending emails failed, NPrinting 17.6

FYI.Qlik Support Solution for SMTP email issue experienced after upgrade 17.6:

This issue will be fixed in the upcoming release of NP 18.0.3 February 2018 release.

annapochyla
New Contributor III

Re: SMTP Server to test sending emails failed, NPrinting 17.6

In our case helped leaving blank fields: User and Password.

Employee
Employee

Re: SMTP Server to test sending emails failed, NPrinting 17.6

Yes, from the February 2018 Release Notes:


Error with SMTP authentication

In some cases, attempts to send emails resulted in the error message “ERROR: No compatible authentication mechanisms found”. The error is generated because the SMTP servers returned  custom headers, instead of standard headers used for accepted authentication methods. This has been resolved by forcing the use of LOGIN (configured username and password), or NTLM authentication if no header was found in the server response.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

Community Browser