Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

cancel
Showing results for 
Search instead for 
Did you mean: 
hugmarcel
Specialist
Specialist

Save NPrinting .skv file as csv

Hi

I'd like to save an NPrinting *.skv file as *.csv. E.g. ticker.skv should be attached as ticker.csv in an email.

I tried to set the filename in the destination folder, does not work.

I tried to set the filename as a custom filename in report definition, does not work either.

Any idea?

Thx a lot - marcel

 

Labels (2)
1 Solution

Accepted Solutions
Lech_Miszkiewicz

Hi @hugmarcel 

That is not really possible. As you know SKV stands for "semicolon separated value" and CSV for "comma separated value" so the only difference is delimiter used ";" or ",".

Since you want to have file with delimiter ";" but you want to save it as CSV the only workaround I can see is to create an object in QlikView which will concatenate all dimensions and measures into single column and use that column in entity report as CSV. Since it will be only single column there will be no issue with the fact that you are using CSV output.

cheers 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

8 Replies
Lech_Miszkiewicz

Hi @hugmarcel 

That is not really possible. As you know SKV stands for "semicolon separated value" and CSV for "comma separated value" so the only difference is delimiter used ";" or ",".

Since you want to have file with delimiter ";" but you want to save it as CSV the only workaround I can see is to create an object in QlikView which will concatenate all dimensions and measures into single column and use that column in entity report as CSV. Since it will be only single column there will be no issue with the fact that you are using CSV output.

cheers 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Ruggero_Piccoli
Support
Support

Hi,,

As per @Lech_Miszkiewicz answer there is not an option to change the file extension; it is set when you select the output format of a report in a publish task.

You could also evaluate to set the Friendly name:

Ruggero_Piccoli_0-1641900656621.png

this doesn't change the file extension but you can deliver an information to the recipient:

Ruggero_Piccoli_1-1641900751109.png

and it is very simple to set.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
hugmarcel
Specialist
Specialist
Author

Your solution works, however, I had to concatenate all values in the script and put the resulting column into a table for QVEntity reporting.

The solution works with Nprinting 16.9 and current version. However, for NPrinting 16.9, I had to put Column Separator(), otherwise I am getting apostrophes " in the resulting csv file:

"100166;20211106;3"

Marcel

hugmarcel
Specialist
Specialist
Author

ok, however, this proposal does not work if it is necessary to import the csv file in an automation process.

Users do not like to change the file name every time in order to read the file with XLS.

Lech_Miszkiewicz

Hi @hugmarcel 

 

1 - Automation process: I am not sure what tools you are using to create automation and obviously it is difficult to say what is possible and what isn't.

2 - Opening in excel: I am little bit confused with this -  You can read SKV files with excel without changing it name. You just have to set excel as default program to open such type of file.

Lech_Miszkiewicz_0-1641944168051.png

That does not solve another problem which you will have regardless of whether the file has CSV or SKV file extension. In Excel columns will not be delimited automatically for SKV files and they will be bunched into single column anyway.

Lech_Miszkiewicz_1-1641944316184.png

 

cheers

Lech

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
hugmarcel
Specialist
Specialist
Author

Hi

I know it's possible to open skv files with excel, and with the "open the file with" feature in windows.

However and working in a a multi client environment, expectation of our customers just is that opening of such files works without having to do so. We do not want 100s of tickets of such kind as "how can I open this file etc.".

It is not user friendly. Thats the problem.

 

Ruggero_Piccoli
Support
Support

Hi @hugmarcel ,

I don't know your custom process but maybe you can evaluate to insert a step to change file extensions.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Lech_Miszkiewicz

Well,

in that case I have given you workaround required to save it as .CSV despite being .SKV file - there is no other option I know of.

 

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.