Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

sanderha
New Contributor

Some errors occurred during report generation

We have a daily scheduled nprinting task, which has a server connection to a Qlikview report.

One day it is running fine, the other day we get the error "Some errors occurred during report generation" in our mailbox.

There's no logic in when it's running fine and when it goes in error. And if we get an error and I run the task again manually, it's possible it's running fine.

The Qlikview report is running a half hour before the NPrinting report, so it's not that the Qlikview task is still running.


Logging scheduler

Connection navigator=qlikview;documentpath=qvp://....qvw has reached ERROR status

Failed report generation for report ... exception Qlik.Reporting.Reports.Tree.Exceptions.FailedReportException: Report generation failed because node CH18 of type Qlik.Reporting.Reports.Tree.Template.TableNode in level root received an ApplyFailureResponse from request ..... ↓↓unknown ---> System.Exception: unknown↓↓  --- End of inner exception stack trace ---↓↓  at Qlik.Reporting.Reports.Tree.Template.TemplateLeafNode`5.ApplyFailure(FailureContentNodeResponse response, TcTransformationContext transformationCtx)↓↓  at Qlik.Printing.Trees.TcTransformation.ApplyResponse(IContentNodeResponse response)↓↓  at Qlik.Printing.TreeTransformationService.Process(IReportRequest reportRequest, IContentNodeResponse contentNodeResponse)


Logging engine

Navigator stuck or died on connection navigator=qlikview;documentpath=qvp://...qvw, forcing close of resolver.

Forced to close a resolver for connection navigator=qlikview;documentpath=qvp://...qvw.

Error while trying to add a resolver for connection navigator=qlikview;documentpath=qvp://...qvw. ERROR: An exception was thrown while invoking the constructor 'Void .ctor(Engine.N


Version NPrinting is 17.3.1

Version Qlikview is 12.10.20200.0 SR4

Please advice us what we can try or do?

11 Replies
pnowicki
Contributor

Re: Some errors occurred during report generation

I'm also seeing this issue with 17.4 - any steps we can take to resolve or debug further?

oggieben
New Contributor

Re: Some errors occurred during report generation

Has anyone answered this, please, as I am getting the same problems.

prisma_d_horvat
Contributor II

Re: Some errors occurred during report generation

Same problem here.. maybe lech_miszkiewicz‌ can give us a tip?

Lech_Miszkiewicz
Honored Contributor III

Re: Some errors occurred during report generation

Hi everyone. I can only say that i came accross this issue and currently i have case logged with Qlik support regarding this and curently it is with Qlik R&D. I will let you know if I learn anything else.

cheers

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
prisma_d_horvat
Contributor II

Re: Some errors occurred during report generation

Thanks Lech, can you tell us in which version the bug is located? Sander has it in 17.3.1 and i use June Version..

Lech_Miszkiewicz
Honored Contributor III

Re: Some errors occurred during report generation

the one i am investigating is in June 2017

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
teempi
Contributor II

Re: Some errors occurred during report generation

Hey,

Did you resolve the issue somehow? I'm also getting the same error.

-Teemu

Lech_Miszkiewicz
Honored Contributor III

Re: Some errors occurred during report generation

I am on version September 2017 and issue is not repeating. I am not sure whether bug was already fixed as my coleague took over this case, but i did not heat about this problem in later releases

regards

Lech

cheers Lech
When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution.
Please LIKE threads if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem.
oggieben
New Contributor

Re: Some errors occurred during report generation

Hi Teemu,

We have moved to the latest version, and so far, no repeat of the issue,

Regards

Chris

Chris Hodges

Project Manager

<http://www.commercialservices.org.uk/>

Commercial Services

Head Office

1 Abbey Wood Road, Kings Hill,

West Malling,

Kent.

ME19 4YT

Tel: 01622 236 782 Mob: 07795 290275

E-mail: chris.hodges@commercialservices.org.uk

Web: www.commercialservices.org.uk<http://www.commercialservices.org.uk/>

<http://www.linkedin.com/company/commercial-services?trk=cp_followed_name_commercial-services>

This e-mail and any attachments are confidential. If you are not the named recipient, please notify the sender immediately. The unauthorised use, disclosure, copying or alteration of this message or its attachments is strictly forbidden.

Commercial Services is a trading style of both Commercial Services Trading Ltd (Reg No. 5858178) and Commercial Services Kent Ltd (Reg No. 5858177) - companies wholly owned by Kent County Council. Registered in England and Wales.

Registered office: 1 Abbey Wood Road, Kings Hill, West Malling, Kent, ME19 4YT.

Community Browser