Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

alexpanjhc
Valued Contributor

filter not working?

I have different filters for different users. each filters I used the user's user name.

I used the filters in the extension object. (as the picture attached). I then pressed the button to send the request to send me a report in my email box.

However, after I got my email (report), i found that the filter is not applied in the report.

Am I using the filter correctly? If not, how should I change this?

Thanks!Capture.PNG

Tags (1)
7 Replies
Employee
Employee

Re: filter not working?

Hi Alex,

It's impossible to guess what your data model is and how your filters are built, on what fields and how they are applied and so on. You need to consider:

* the values selected in Current Selections for the User field  - if any

* filters on the User field applied on the Task/Report/Object in the NSQ

* user level filters

Take a look at this article to learn which filters take precedence, how Current Selections & Additional saved Filters work together etc.: How to Use Current Selections with On-Demand Reporting

HTH - Daniel.

alexpanjhc
Valued Contributor

Re: filter not working?

Hi Daniel

Thanks for replying.

Let me elaborate a bit more.

I manually put the filter in my report, and I ran the task. The report has what I expected results.

When I added filer in the additional saved filter(in my original post) on access point, it is not giving me expected report. though current selection is working. It is just not filtering out what I had asked for.

Does that make sense?

Re: filter not working?

Alex,

1) Is there any restriction from client to filter in Access point?

2) Why you want to add there, Directly?

- Anil

alexpanjhc
Valued Contributor

Re: filter not working?

Anil,

I need to workaround the section access. For each user, I created a filter and when applying the filter, that will do the same as what section access does.

Re: filter not working?

Is there any chance to show the DM for Ref...

alexpanjhc
Valued Contributor

Re: filter not working?

Why is it matter to the DM?

The DM is very complicated anyway. It is not possible to understand without explanation, The screenshot will be to congested to read.

Employee
Employee

Re: filter not working?

Hi Alex,

I would have different recipient filters for each recipient in the NSQ - I think you already have this. In the QlikView document I would populate the Additional recipients expression instead of the Additional saved filters:

I would build the task without any recipients - you will get a warning that a recipient is required when send to e-mail is checked but you can continue anyway without adding one. When the on-demand task is triggered it will add the recipient and apply the recipient level filters.

HTH - Daniel.

Community Browser