Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

nPrinting Condition issue

Hi Experts,

let me explain my scenario:

I want to send reports from a table in QV to different email addresses using nPrinting 16.7
 
Department Value
1123
2456
3783
 
each address scould only get the lines from the table depend on its department:
 
emailAddress 1 gets only Department 1 values as PDF attached
emailAddress 2 gets only Department 2 values as PDF attached
...
 
my solution:
 
Qlikview entitiy Report 
  1. Cycle: Department
  2. Filter: Today (to send only today data)
  3. Condition: vDepartment > 0 defined in QV  as max(Department) and Chart has Values
recipient:
a with Filter Department 1
b with Filter Department 2
c with Filter Department 3
 
It works fine, if the table has values for all Departments but if one Department is missing the condition does´nt work as expected.
i.e.:  There is no data for Department 3 at report creation time -->recipient c  gets 2 PDFs: Department 1 and 2!
 
How can i handle this problem?
 
Thanks for your response!
Labels (2)
1 Solution

Accepted Solutions
Highlighted
Employee
Employee

Hi,

Ok, now I understand. You need to add cycles to be able to add the department name in the file name but cycling on the same field used in recipient filters will cause issues with the results.

You could create a QlikView variable with the formula GetFieldSelections() ( https://help.qlik.com/en-US/qlikview/April2019/Subsystems/Client/Content/QV_QlikView/ChartFunctions/... ) and specify that you want to have a single value. Then you insert this formula in the file name. I have not tried.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

8 Replies
Highlighted
Employee
Employee

Hi,

Did you enabled the Verify filters option on the filters?

I think you should create the condition only to check if the table has data.

If each recipient has a filter to receive only data from a department why are you also cycling? You should use cycles only if you want to create different files for each distinct value of a specific field. In this case it seems a duplicate cycling on department and apply a filter on department for each user. Each recipient with filters will receive a different file without the need of cycling.

This could also create troubles in QlikView NPrinting 16 because it is like when you click two times on the same value of a field in QlikView Desktop. The first click applies the filter and the second removes it. This could explains why a recipient is receiving unfiltered data. 

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Contributor III
Contributor III

Thanks Ruggero for your reply!

yes, i enabled the Verify filter option on the filters.

Cycling is because of dynamic naming of reports based on Department. I coud'nt find another way to do that. Do you have any Suggestion?

Best regards,

Arash

Highlighted
Employee
Employee

Hi,

It is not necessary to cycle to enable dynamic naming. You can simply check the Enable Dynamic Naming flag and configure it. 

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Contributor III
Contributor III

Hi,

i did'nt understand, how can i configure it without Cycle Field (Department)? I tried with Qlikview Variable, but it did'nt work ...

Best

Arash

 

Highlighted
Employee
Employee

enable.png



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Highlighted
Contributor III
Contributor III

 
 

But the report name schould be something like : Date-Reportname-Department.

And i tried it without Cycling but my mentioned problemat the top is not solved even without Cycling ...

Best regards

Arash

 

Highlighted
Employee
Employee

Hi,

Ok, now I understand. You need to add cycles to be able to add the department name in the file name but cycling on the same field used in recipient filters will cause issues with the results.

You could create a QlikView variable with the formula GetFieldSelections() ( https://help.qlik.com/en-US/qlikview/April2019/Subsystems/Client/Content/QV_QlikView/ChartFunctions/... ) and specify that you want to have a single value. Then you insert this formula in the file name. I have not tried.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.

View solution in original post

Highlighted
Contributor III
Contributor III

Hi,

thank you!

My Condition did´nt work with the Variable becasuse i definded it in QV as Max(Department) now it works with your suggestion using GetFieldSelections().

Best regards

Arash