Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
mp802377
Creator
Creator

nPrinting Excel table populating blank spreadsheet

 

Hello,

I have an application in Qlikview that imports new users and what reports they want. The plan is to have nPrinting pull this into an Excel file (https://help.qlik.com/en-US/nprinting/May2021/Content/NPrinting/DeployingQVNprinting/Import-Users-Fi...). Then nPrinting will pull all the users in for a PDF report that is to be emailed on a specific day of the week. You can see there is data in the app. I have refreshed the connection multiple times. But yet, (see the last image) there is nothing in the Excel document. 

This is nPrinting20


Thank you 

Martha

 

Qlikview app for nPrinting.jpg

 

Qlikview app for nPrinting2.jpg

 

Qlikview app for nPrinting3.jpg

 

 

Labels (2)
1 Solution

Accepted Solutions
Lech_Miszkiewicz

It is probably section access or data reduction or if you use publisher there may be loop and reduce used... or simply different access level to the source from where data is loaded to qvw so that service accounts dont have access to the same list you do. 

interesting one.

Lesson learned - always compare nprinting report to the actual source 🙂 

cheers

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

6 Replies
Frank_S
Support
Support

Hi @mp802377

Can you please remove the 'properties' panel in the lower left corner of the NP designer (click on the red 'x') and show all expanded filter items and screenshot. I want determine if the tags you are using in the template are correct.

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
mp802377
Creator
Creator
Author

mp802377_0-1627502010690.png

 

Frank_S
Support
Support

Thank you.

The tags look accurate.

 

Next:

  • Verify your source NPrinting Connection in the NP web console/connections.There should no verification errors. (also ensure you are connected to the QVW that you expect to extract data from. (if using publisher for example ensure that the source document/qvw contains data. If needed, try using a local copy of the QVW and use a local NP connection to the QVW for testing purposes).
  • reload the NP connection
  • right click one each table object (ch04,05 and 6) individually and select update from the context menu and select 'update'
  • Preview the report

Does it work now?

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Lech_Miszkiewicz

I would add to this:

  • Are there any filters in play (linked to task, report or a user?)
  • Is it possible tha your source app is not supported (have some unsupported objects like always one selected value, triggers etc...)
  • Can you also specify the exact version of your QlikView (Server and Desktop) and NPrinting?

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
mp802377
Creator
Creator
Author

I realized this isn't an nPrinting issue. When I have the Qlikview application open (this is the Qlikview application that is used to populate the data for nPrinting), I see data (as you can see from the first image). The moment nPrinting or the QMC runs it, the data disappears. But I run it in the DEV environment and the data is there. 

I don't know what is causing this, that is a separate issue entirely. In my years of working with Qlikview, I have never seen anything like that.

 

I thank you all for your help.

Lech_Miszkiewicz

It is probably section access or data reduction or if you use publisher there may be loop and reduce used... or simply different access level to the source from where data is loaded to qvw so that service accounts dont have access to the same list you do. 

interesting one.

Lesson learned - always compare nprinting report to the actual source 🙂 

cheers

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.