Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Qlik Analytics Tour 2020 Online. Begins August 10th. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

nPrinting QlikSense new variables not accessible

I have a qliksense app and nPrinting setup. I have been using emails output off an excel template.

2 things.

 

1. I CANNOT get a simple variable as a condition to allow/ prevent an email from sending.

from the rule: Variable      vHowMany   <     Constant    150

Even when I see the KPI on the app showing less than 150 for the equivalent filter used....the task FAILS

 

2. To test a separate variable, I created a second variable. Even after I run the Generate Metadata successfully [ multiple times] the new variable is NOT showing up when I try to set a different rule as a condition NOR does it show up if I try to add the variable to the template objects.

 

What am I missing?

 

Labels (2)
1 Reply
Highlighted

this is not enough information to answer your question. We need to see what is the variable value. If it is set in script please share code on how you set it if it is set in UI as an expression also show us how you have set it up. I am assuming your variable is not expanding and it is well described on https://help.qlik.com.

When you say: Even when I see the KPI on the app showing less than 150 for the equivalent filter used....the task FAILS, 

I am assuming your KPI object is expanding variable and NPrinting works differently when working with variables as it is documented below:

https://help.qlik.com/en-US/nprinting/February2020/Content/NPrinting/Troubleshooting/Variables-dont-...

 

Your second issue is hard to debug in community. I would ask ridiculous questions like:

  • Is the variable in the app you are connecting to (as maybe you have app published, you could duplicated it, add variable and forgot to re-publish it again)
  • Did you allow for app to save and load before you regenerated metadata? Usually takes a minute....
  • Did you try to bring in/search for this variable in excel template editor?
cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.