Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

megabyte23
New Contributor III

nPrinting .xlsx report attachment no data (blank)

Hello,

I've found a number of posts about this and tried everything I found, but I can't figure out what I'm doing wrong. Everything works fine - the connection says "Connection successful on all NPrinting engines."

I've verified the report has information. It is a straight table chart on a single tab in the .qvw and published on the server.

I set up a trigger and it sends the email with an attachment, but there is no data in the attachment.

I'm looking for other suggestions. Thanks for your help.

1 Solution

Accepted Solutions
Employee
Employee

Re: nPrinting .xlsx report attachment no data (blank)

Hi,

17.3.1.0 is very old. Please update to latest version before proceed. There are a lot of solved bugs between 17.3.1.0 and September 2018 and I suspect that some of them are the origin of your issue.

Then we need a screenshot of the template, I mean the structure of the template not the data. The reason is to create a similar one to try to replicate.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
10 Replies

Re: nPrinting .xlsx report attachment no data (blank)

Hi Meg,

Lets start with the basics:

  • Please provide versions of Qlik and NPrinitng + their SR numbers
  • Maybe screenshot your report and report preview
  • Are there any User filters for connection you are using for this report?
  • Is there section access?

With the information currently provided we cannot give you straight answer..

regards

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Highlighted
alan_richmond
Contributor

Re: nPrinting .xlsx report attachment no data (blank)

I have the same Lech

I have recently updated to the September 2018 patch 182980

I deleted a column from the table to be created in the report

Preview the template, now no data returned

the same when executed as a task

The data source is a dedicated qv document with no section access

the data is visible using the same filters in the QV document

alan_richmond
Contributor

Re: nPrinting .xlsx report attachment no data (blank)

I reengineered my report and removed the levels and the new report works fine

Maybe an issue with levels in the new version

Re: nPrinting .xlsx report attachment no data (blank)

I have not experienced this behavior and would have to test it.

It would be interesting to know if your re-engineered  report will work once you add levels in it again. I am thinking that it can be a template bug, loosing information about report layout after an upgrade to newer NPrinting version. If i am right then we will have to raise bug with Qlik Support.

regards

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Employee
Employee

Re: nPrinting .xlsx report attachment no data (blank)

Hi,

At the moment there are not know issues with Levels. Please supply here all the information requested by Lech in order to let us to try to replicate your issue. Describe in details what you are doing.

If you cannot post here, open a support ticket to let the support guys to investigate. In this case please post the solution when done.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
megabyte23
New Contributor III

Re: nPrinting .xlsx report attachment no data (blank)

Thank you Lech, here are the details:

  • Versions:
    • QlikView 12.10 (I pulled this from QMC, I hope this refers to the actual server version)
    • nPrinting Version: 17.3.1.0
    • QlikView 12.0.20400.0 SR5 64-bit Edition (pulled from my desktop install, I assume that's the "SR Number")

  • Maybe screenshot your report and report preview
    • I added a screenshot it from the portal, though I don't know that it tells much other than there is data populated (I erased so I could share it)
  • Are there any User filters for connection you are using for this report?
    • No filters
  • Is there section access?
    • No section access. I double checked that it didn't get turned on somewhere by accident:
      • Checked for a hidden script
      • Checked on QMC and section access is not selected

We did change the name at one point, but I can't see where that would be causing a problem.

I'm attaching a screenshot of the report as it shows up blank in my email- you will notice a weird thing which is a Qlik developer is marked as the author "Andrea Franco", so maybe it's pulling this from some weird cache somewhere?

Employee
Employee

Re: nPrinting .xlsx report attachment no data (blank)

Hi,

17.3.1.0 is very old. Please update to latest version before proceed. There are a lot of solved bugs between 17.3.1.0 and September 2018 and I suspect that some of them are the origin of your issue.

Then we need a screenshot of the template, I mean the structure of the template not the data. The reason is to create a similar one to try to replicate.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT https://community.qlik.com/docs/DOC-14806. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
megabyte23
New Contributor III

Re: nPrinting .xlsx report attachment no data (blank)

Ugh, ok. I'll report back in about 6 months when they approve the upgrade LOL.

It just seems so strange because I have a very similar report doing the exact same thing and it works fine.

Thanks for your help.

Re: nPrinting .xlsx report attachment no data (blank)

I totaly agree with Rugerro. 17.3.1 is super old. Between your version and current you probably could list 100+bug fixes and overal improvements!

Given that your version is so old i would not compare one report with similar another report.

On the other hand - i suggest you improve your apporval process for upgrades. NPrinitng gets released around 4 times a year with major upgrades and bug fixes so there is a lot you can gain from them.

regards

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.