Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
ioannaiogr
Creator
Creator

report isn't distributed to the assigned user e-mail

Hello experts.

Today i faced this issue:

I created a user called "test user", assigned them the e-mail user1@blabla.com    (fake mail for the sake of a paradigm) .

I also created a publisk task, picked the recipient to be the user "test user". In the Destinations segment I only checked the publish to e-mail for this user (not the NewsStand). Now, in the e-mail segment of publish task for the recipient email i pick from the drop down list the "User E-mail" and this is what i see (look at attached picture), a grey box with User_Email_Address on it as the address. I click on save, create the trigger, run the task and I don't receive the report to the user email  user1@blabla.com.   

BUT if I manually insert the mail and do all the above, even if i already picked the user with THIS mail to be the recipient, only then it works.

I also watched the video for Qlik Printing May 2021 https://help.qlik.com/en-US/nprinting/May2021/Content/NPrinting/DistributionSchedulesAutomation/Dist... and there is a screenshot I attach where the e-mail in publish task environment is different and does not show email to "selected users and CC/BC".

I'm a tad confused.

Please help? I'm thinking it's okay to insert only one mail by hand, but when it's going to be almost <100 users, this won't be effective.

 

Looking forward to learn from you guys!

Labels (2)
1 Solution

Accepted Solutions
ioannaiogr
Creator
Creator
Author

Okay, found out that in Admin < Security Roles< User was disabled. 

The domain field in user profile is mandatory for the distribution to work?

View solution in original post

8 Replies
AshutoshBhumkar
Partner
Partner

Hi,

Please check for the user role. It should be 'User'.

 

Thanks,
Ashutosh

ioannaiogr
Creator
Creator
Author

Hi @AshutoshBhumkar ,

oh I forgot to mention- it's already set as Role "User".

AshutoshBhumkar
Partner
Partner

Hello,

Could you please check again if the user is enabled or not. Otherwise it should work.

Check logs in the task execution.

 

Thanks,

Ashutosh

Lech_Miszkiewicz

Based on what you said I can only assume that you have entered email wrongly in user profile. 

If you only had that one user in user/group section of publish task that means that all other user  atributes are working ok as sending it to manualy email entry worked. 

And you did not tell us what you got in execution task log for the failed runs?  What does it say there? There is usually a clue which would help indicate what is wrong.

 

thanks

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
ioannaiogr
Creator
Creator
Author

Hi everyone.

Well: 

1) user is enabled

2) user has the role "user"

3) locale and everything is set up

4)the mail which i write manually to the recipient section and the mail assigned to the user profile is the same

5) task execution says all tasks are completed 100%, no error message

Maybe it's something with the domain, i don't really know... 

Else, I'm curious what else could go wrong.

 

ioannaiogr
Creator
Creator
Author

UPDATE

October 15, 2021 3:53:00 PMWarnThe user listed in task  does not have permission to view one or more reports attached to the task. Reports won't be published in the newsstand destination.
October 15, 2021 3:53:00 PMWarnThe user listed in task  does not have permission to view one or more reports attached to the task. No email will be sent.
ioannaiogr
Creator
Creator
Author

Okay, found out that in Admin < Security Roles< User was disabled. 

The domain field in user profile is mandatory for the distribution to work?

View solution in original post

Ruggero_Piccoli
Employee
Employee

Hi,

No, domain user is to use the Windows authentication but you can deliver reports via email also without it. 

Follow the Best Practices listed in https://help.qlik.com/en-US/nprinting/May2021/Content/NPrinting/AdministeringQVNprinting/Set-up-emai... to avoid the most common errors with the delivery via email.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.