Skip to main content
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

NPrinting engine remains offline

Hi All,

NPrinting engine remains offline & status does not change to online. I checked the logs & below error appears in scheduler logs:

Exception caught        Qlik.NPrinting.Repo.ServiceException: Lef File Server Unreachable

I have activated the license offline & it says activation successful.

Has anyone encountered this error before?


Best Regards,


Labels (2)
14 Replies


MMC is for Microsoft Management Console. Refer to official Microsoft documentation about how to use it.

Best Regards,


Best Regards,
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
Partner - Contributor III
Partner - Contributor III

Hi Bastien,

I repeated your solution more than 20 times, I am absolutely sure that there is a bug on Nov 2018 version.

I tried on win 2012, 2016 and on a fresh installation , it doesnt work at all.

I also tried to install Sep2018 on a fresh installation, then restore my data, then upgrade to Nov2018, still same issue.

The only result differences between what I got and you posted is

I don't see this line in my log file " Engine Consumer started successfully.

it is as  

Starting up Engine service

Certificates exchange HTTP server listening on http://localhost:4997/

Starting RabbitMQ connection using certificate E10B06DE1D0446B0522236162CB619C475244CA6

Slave Engine Service started successfully

Also, in the Sep2018 version I noticed certificate friendly name is as nprinting server, but when I install freshh NOv 2018 version or remove the engine and define, I dont see any friendly name in the certificate (in case if friendly name is a matter)


Hope you can help 


Contributor II
Contributor II

Hi All,

we have tested, by enabling TLS 1.0 engine comes online. do test please follow  

  1. Start the registry editor by clicking on Start and Run. Type in "regedit" into the Run field (without quotations).
  2. Highlight Computer at the top of the registry tree.  Backup the registry first by clicking on File and then on Export.  Select a file location to save the registry file.

    Note: You will be editing the registry.  This could have detrimental effects on your computer if done incorrectly, so it is strongly advised to make a backup.

  1. browse to the following registry key:

  2. Right click on the Protocols folder and select New and then Key from the drop-down menu. This will create new folder.  Rename this folder to TLS 1.1 or TLS 1.2 (depending on the protocol you want to enable)

  3. Right click on the TLS 1.1 or TLS 1.2 key and add a new key underneath it.
  4. Rename the new key as:
    • Client
  5. Right click on the Client key and select New and then DWORD (32-bit) Value from the drop-down list.
  6. Rename the DWORD to DisabledByDefault.
  7. Right-click the name DisabledByDefault and select Modify... from the drop-down menu.
  8. Ensure that the Value data field is set to 0 and the Base is Hexadecimal.  Click on OK.
  9. Create another DWORD for the Client key as you did in Step 7.
  10. Rename this second DWORD to Enabled.
  11. Right-click the name Enabled and select Modify... from the drop-down menu.
  12. Ensure that the Value data field is set to 1 and the Base is Hexadecimal. Click on OK.
  13. Reboot the server

After the reboot, the server will be able to communicate through the SSL protocol you enabled. However, you need now to add it to your applications requests.


one of my customer has tried and proved that enable TLS 1.0/1.2 solved the issue



Qlik Technical Support
Contributor II
Contributor II


Tried enabling TLS 1.0 but it didn't work.

I installed September 2018 version which is working fine.

Best Regards,