Skip to main content
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

On Demand not working in Qlik Sense

Hello Folks,

I am trying to configure the On Demand feature of Qliksense in Nprinting report but getting the below error while configuring the connection under Nprinting Server Connection in extension.

"Failed To get Data from External resource".

Below are the steps taken by me in order to achieve the same and screeshots.

- Dowloaded Extension "Nprinting On Demand" and imported into an app.

- Added Nprinting server connection details under "Nprinting Connetion" tab of extension.

- Added Qliksense server details under "On demand Setting" in Nprinting server.

-Enabled on On Demand and API report generation in report setting.

Is there any step which i missed. Kindly help 

OnDemand Connection.png

12 Replies
Partner - Creator II
Partner - Creator II

Hello Amarti,

it's a reach but if you're using chrome try resetting all experimental features. I had issues with the on demand extension two weeks ago and this was the only thing that worked for me (I even reinstalled the whole NPrinting-Server). 

1. Navigate to "chrome://flags/

2. Click "Reset all to default" on the top right

I remember changing something in there a year ago, don't know what it was but after I pressed reset and closed / reopened chrome the extension worked without any further issues.

If you want more details on whats going on you can also open the developer console by pressing "F12" while you're on a the Qlik Sense sheet containing the On-Demand-Extension. You should see an error in the console and more details in the "Network"-tab.

In my case, the error response alternated between a 400 Bad Request (CORS-Header missing even though I added it in the admin panel) and a  403 Forbidden (a JSONresponse containing "user does not have permission to this resource" even though my user was an NPrinting administrator)



Partner - Contributor III
Partner - Contributor III

Hi Mathias,

the problem was related to NPrinting firewall, now it's working fine.



Partner - Contributor III
Partner - Contributor III

Hi Ruggero,

You're right! Anyway, I already figured it out and it was a problem with NP firewall.