Qlik Community

Ask a Question

Qlik Replicate

Discussion board for collaboration on Qlik Replicate.

cancel
Showing results for 
Search instead for 
Did you mean: 
Attunity_user
Contributor III
Contributor III

Huge delay reading logs from the source server transfer to attunity server

Hello,

We have been running into issue of Attunity not able to pace with the changes from source (Oracle) to target (Oracle) and ending up error with missing the below error in production.  

I am looking for people's experiences of how this tool is successfully configured from a source that sends massive changes that occur every second.  This includes the server installed on which OS, archive log settings, network settings, etc.

 

Archived Redo log with the sequence #### does not exist, thread 1.

Captured logs by turning on performance and there is huge latency build up over the time.  The delay is between the source server transferring a file to Attunity server.

[PERFORMANCE ]T: Completed to read from online Redo log 40##### bytes at offset 0000000037281400 with rc 1, read time is 2252 ms, thread '1'

later...

and read time is 53635 ms, thread '1' (oradcdc_redo.c:877)

We are not able to get this work.

Thanks

AU

2 Solutions

Accepted Solutions
stevenguyen
Contributor II
Contributor II

6.4.404 is SP6 ,, 

current 6.4 is SP17 6.4.0.534, best that you open a support ticket to get the latest version and test with latest version.

View solution in original post

stevenguyen
Contributor II
Contributor II

1. if archive is setup for 24 hours, and error Archived Redo log with the sequence 492617 does not exist, thread 1

- you would need to reload.

2. setup performance for trace to see where the latency is at, source or target.

3. you may want to look at logstream, where target is writing to files on Replicate server.

View solution in original post

10 Replies
stevenguyen
Contributor II
Contributor II

i remember there was some issue with older kit where it can not read thread 1, so best that you are on the latest service pack 6.4 or latest service pack 6.5

- then if you still have issue, post back.

Attunity_user
Contributor III
Contributor III
Author

Hi Stevenguyen,

 

Thank you for your response. The version we installed is below.

attunity replicate/6.4.0.404

 

Thanks,

AU

stevenguyen
Contributor II
Contributor II

6.4.404 is SP6 ,, 

current 6.4 is SP17 6.4.0.534, best that you open a support ticket to get the latest version and test with latest version.

View solution in original post

Attunity_user
Contributor III
Contributor III
Author

Stevenguyen:

 

As suggested, we installed the latest version, 6.5.0.354 , on all three environments including production.  The task still fails with below error after a day.  The archive set up in the source side is 24 hrs and cannot be extended. But the issue is again latency.  It continuously build up over the time and end up with the below error.

 

Archived Redo log with the sequence 492617 does not exist, thread 1

 

We are not sure why the tasks cannot catch up reading logs faster with the pace of transactional changes.

 

Thanks,

AU

stevenguyen
Contributor II
Contributor II

1. if archive is setup for 24 hours, and error Archived Redo log with the sequence 492617 does not exist, thread 1

- you would need to reload.

2. setup performance for trace to see where the latency is at, source or target.

3. you may want to look at logstream, where target is writing to files on Replicate server.

View solution in original post

Attunity_user
Contributor III
Contributor III
Author

hi,

Since this failure happens every second day, reload is not a viable solution.

 

2. setup performance for trace to see where the latency is at, source or target.

Done that, and the performance/latency is on reading the archive logs + transfer the file to the attunity server. We use attunity log reader.

3. you may want to look at logstream, where target is writing to files on Replicate server.

Writing to a file on a replicate server.

 

Thanks,

AU

MermaidMe
Contributor II
Contributor II

Hi Steven,

Would you be able to read the below article, it helped me fix this to an extent by setting  readAheadBlocks=500000 with a retention period of 4hrs on the Oracle source. Again recommend discuss it with any of the technicians in the Qlik Support Team.

https://attunitysupport.qlik.com/s/article/Optimize-read-speed-from-Oracle-ASM

 

Thank You,

Maneesha T

Attunity_user
Contributor III
Contributor III
Author

Hi Maneesha,

 

Where is this readAheadBlocks=500000 that we can change it in the replication configuration?

Galit_Spivak
Employee
Employee

Hi

readAheadBlocks  is internal Qlik Replicate parameters.

(manage endpoint connection -> your endpoint -> advanced tab -> internal parameters)

 

Have a good day