Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 
AKV0524
Contributor III
Contributor III

Not able to connect to ibm db2 i series vis Qlik replicate

we are trying to connect ibm db 2i serires as 400 system from qlik replicate but is giving error. we have already installed required driver but still it is not able to connect.
we have already open port and can do telnet and ping to database but from qlik replicate it is giving error to connect to source. From dbeaver tool we are able to connect via jdbc url.

Labels (1)
10 Replies
john_wang
Support
Support

Hello @AKV0524 ,

Thanks for reaching out.

Mostly the problem was caused by connection between DB2 Client and DB2 Server,  for example the connection or VPN issue, or TCP/IP Port were not enabled in firewall etc.  I'm not very where the DBeaver is running, is it from the Replicate Server machine ? We'd like to suggest to create an 64-bit ODBC DSN on Replicate Server to troubleshoot the connectivity issue, it's almost as same as Replicate APIs calls. If the ODBC DSN works then Replicate should work as well.

Hope this  helps.

Regards,

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
john_wang
Support
Support

Hello @AKV0524 ,

BTW, please make sure the password is correct. AS I remember we got the same error with incorrect password in Replicate Endpoint.

Regards,

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
AKV0524
Contributor III
Contributor III
Author

Hi Wang,

yes dbeaver is running from replicate server only we have created a odbc dsn as well but still it is not working.

from the dbeaver we are able to connect via jdbc url connection but not from host connection.

we have created a support case as well today for the same issue but no response.

 

By Any chance Attunity connects to ibm db2 i series via jdbc connection. i know it is not possible according to user guide but a thought.

 

Thanks

Amit

john_wang
Support
Support

Hello @AKV0524 ,

Thanks for the info.


@AKV0524 wrote:

... we have created a odbc dsn as well but still it is not working.


Do you mean access to the DSN got the same error? If yes then it's a pure DB2 client/server connectivity side issue. In this case we need your IT/DBA help as well.


@AKV0524 wrote:

we have created a support case as well today for the same issue but no response.


Sorry about that. Seems I'm not lucky to find it in Support System. May we know what's the case number? Our support team will help to look into it for you.

Regards,

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
AKV0524
Contributor III
Contributor III
Author

Hi Wang,

 

we have created support case 00081094 yesterday but till now no response. can you please help here and may be we can schedule call with qlik support team we will bring source db team as well firewall team as well. we are not able to find what is blocking the issue.

john_wang
Support
Support

Hello @AKV0524 ,

Thanks for the information.

We noticed you marked the source DB typs "AIS DB2 on iSeries" in the case,  as AIS had reached its end of support (EOS) date, support team is confirming with you if this is a PoC case, or a typo, or you are using ARC ? if any reason the DB2i Native driver endpoint is not used in the project? Please confirm.

BTW, our support team will contact you via support case.

Thank you,

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
AKV0524
Contributor III
Contributor III
Author

Hi John,

sorry my bad that's a typo mistake.source is ibm db2 i series as 400. we have installed the correct required driver in Attunity server.

Thanks

Amit

john_wang
Support
Support

Hello @AKV0524 ,

No worries! I'd updated support team already.

Regards,

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
AKV0524
Contributor III
Contributor III
Author

thankyou john. i will wait for support team to connect.