Qlik Community

Qlik Replicate

Discussion board for collaboration on Qlik Replicate.

Announcements
June 28, 10AM ET: Qlik Nation and Qlik Community present: CyberSleuth REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Benkku
Partner
Partner

Not able to connect with TimescaleCloud (PostgreSQL)

Hi!

I am trying to create a demo for a customer with Qlik replicate. The end point shall be TimescaleCloud. I am using the PostgreSQL connector.

Here are the details of my Timescale Cloud service:

ID_12_Cloud.pngID_13_Cloud.pngID_14_Cloud.png

I have downloaded the CA Certificate and stored it in the server where Replicate is running @: C:\Users\PengonAdmin\Benkku\pv\ca.pem

This is the endpoint configuration in Qlik Replicate:

ID_6_target_endpoint_cloud.pngID_7_target_endpoint_cloud_2.png

When testing the connection, I get the following error:

QLIK_Replicate_TimescaleCloud_ERROR.png

Any hint?

Thanks,

Bernardo Di Chiara

Labels (2)
1 Solution

Accepted Solutions
Benkku
Partner
Partner
Author

Hi Ted!

Thanks for your answer!

Actually the problem was a missing configuration (the System Variable PATH).

I copy below the answer I got from Qlik Support.

Best Regards,

Bernardo

***

The error message you´re getting is caused due to missing PostgreSQL drivers or the $PATH environment variable not being set to point to the corresponding PostgreSQL directory.

The below user guide article contains more information on setting up PostgreSQL-based endpoints:

Prerequisites

The following topic describes the client prerequisites when replicating to a PostgreSQL target.

  • Qlik Replicate Server for Windows:
    • The PostgreSQL ODBC Driver: PostgreSQL ODBC Driver psqlodbc_12_02_0000-x64 or above must be installed on the Qlik Replicate machine.

    • Postgresql-binaries:

      1. Download postgresql-12.6-3-windows-x64-binaries.zip.
      2. Copy the bin folder to a Replicate machine.
      3. Add the bin folder path to the system PATH.
      Note:

      If PostgreSQL binaries and the Greenplum client are deployed on the same Replicate Server, tasks configured to use a PostgreSQL target will fail.

    • Microsoft Visual Studio 2013 Redistributable (x86) - not (x64) - must be installed on the Qlik Replicate machine.

SOURCE: https://help.qlik.com/en-US/replicate/May2021/Content/Replicate/Main/PostgreSQL/prereq_postgresql_ta...

 

The below article explains how to navigate and edit the System Variable PATH.
https://www.architectryan.com/2018/03/17/add-to-the-path-on-windows-10/

Once you´ve added the bin folder to the System Variable PATH, then please restart the Replicate services and please try again.

View solution in original post

2 Replies
Ted_Manka
Support
Support

Hello @Benkku ,

 

PostGres 13 is not supported yet (should be supported in late August 2021)....but I don't think that your error corresponds to that...there are some pre-reqs that need to be satisfied did you follow the steps in the user guide for setup to postgres exactly?  Can you detail what you have done so far?

 

Best,

Ted

Benkku
Partner
Partner
Author

Hi Ted!

Thanks for your answer!

Actually the problem was a missing configuration (the System Variable PATH).

I copy below the answer I got from Qlik Support.

Best Regards,

Bernardo

***

The error message you´re getting is caused due to missing PostgreSQL drivers or the $PATH environment variable not being set to point to the corresponding PostgreSQL directory.

The below user guide article contains more information on setting up PostgreSQL-based endpoints:

Prerequisites

The following topic describes the client prerequisites when replicating to a PostgreSQL target.

  • Qlik Replicate Server for Windows:
    • The PostgreSQL ODBC Driver: PostgreSQL ODBC Driver psqlodbc_12_02_0000-x64 or above must be installed on the Qlik Replicate machine.

    • Postgresql-binaries:

      1. Download postgresql-12.6-3-windows-x64-binaries.zip.
      2. Copy the bin folder to a Replicate machine.
      3. Add the bin folder path to the system PATH.
      Note:

      If PostgreSQL binaries and the Greenplum client are deployed on the same Replicate Server, tasks configured to use a PostgreSQL target will fail.

    • Microsoft Visual Studio 2013 Redistributable (x86) - not (x64) - must be installed on the Qlik Replicate machine.

SOURCE: https://help.qlik.com/en-US/replicate/May2021/Content/Replicate/Main/PostgreSQL/prereq_postgresql_ta...

 

The below article explains how to navigate and edit the System Variable PATH.
https://www.architectryan.com/2018/03/17/add-to-the-path-on-windows-10/

Once you´ve added the bin folder to the System Variable PATH, then please restart the Replicate services and please try again.