Unlock a world of possibilities! Login now and discover the exclusive benefits awaiting you.
We are replicating from source SQL server 2022 into target Snowflake. We have ODBC 17 and installed ODBC 18 into the server. After installing, the task been running fine. After several hours, however it started to give error.
Hello Desmond, @desmondchew
The error is not related to the ODBC Driver 18. It appears to be a permission issue.
Could you please try running the following query manually using the produser account?
select 1 FROM sys.dm_db_partition_stats;
If the required permissions are in place, the query should return rows.
If not, SQL Server will return an error indicating any additional permissions are required.
thanks,
John.
I login as the Qlik user - prod and able to run the query. Doesn't seem like a permission issue.
Hello Desmond, @desmondchew
Thanks for the update.
Could you please try running the same test against another table as well? For example:
Hi John,
Thank you. We have identified the issue. It is due to a blocking session in the source database. Once we killed that session, replica is able to move.
Desmond