Skip to main content

Qlik Replicate

Discussion board for collaboration on Qlik Replicate.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $400 before Dec 31st: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
bilzekek
Contributor III
Contributor III

Replicate Store changes task error: peform_row_lookup(...) failed to look up change data for table

Hi,

I have a Replicate task running with "store changes" enabled. In the task, I have configured a table specific filter, to only include rows where language = 'EN' (See below).

Source is MS SQL server and the specific table has two columns for key:

bilzekek_0-1663836584130.png

I have enabled the task and it has been running for a few hours, but I am now getting an error, as shown below

bilzekek_1-1663837435604.png

My guess is that Replicate has to lookup another column in the table because of a long string, but has an issue with a row that contains empty value in key column 'Language'. Because I have the filter, it probably doesn't have an effect on the target, but it is quite annoying to keep receiving the error.

If my assumption is correct, is there anything I can do here ?

otherwise, what is the issue here ?

 

Labels (1)
1 Solution

Accepted Solutions
SachinB
Support
Support

Hello @bilzekek ,

Most likely the PK value was in a section of the log record beyond the 8000 byte limit of the API that we use.

If the error continues to happen, you may need to convert to using the direct access method of reading the transaction log and switch to backups only.

 

If the issue still did not resolve, We would request to create case and attach required logs and diagnostic package  for our analysis, We will take it further 

 

Regards,

Sachin B

 

View solution in original post

4 Replies
SachinB
Support
Support

Hello @bilzekek ,

Most likely the PK value was in a section of the log record beyond the 8000 byte limit of the API that we use.

If the error continues to happen, you may need to convert to using the direct access method of reading the transaction log and switch to backups only.

 

If the issue still did not resolve, We would request to create case and attach required logs and diagnostic package  for our analysis, We will take it further 

 

Regards,

Sachin B

 

bilzekek
Contributor III
Contributor III
Author

Hi Sachin B,

Thanks for the response.

Can you guide me to how I convert to use direct access ? is this an end-point setting?

SachinB
Support
Support

Hello @bilzekek ,

To configure direct access method, set the source endpoint to "Replicate has file-level access to the backup log file " in the advanced settings.

https://help.qlik.com/en-US/replicate/November2021/Content/Replicate/Main/SQL%20Server/SQLServerDBSo...

We would also request you to create a support ticket in order to deep dive the issue.

 

Regards,

Sachin B

bilzekek
Contributor III
Contributor III
Author

Hi Sachin,

Thanks, will do this 🙂