Skip to main content

Qlik Replicate

Discussion board for collaboration on Qlik Replicate.

Announcements
Skip the ticket, Chat with Qlik Support instead for instant assistance.
cancel
Showing results for 
Search instead for 
Did you mean: 
kyhutch_mdb
Partner - Contributor
Partner - Contributor

Replicate UI doesn't start correctly, have to server rebuild to restore functionality

When using CentOS7 after restarting a server the Replicate UI does not start up correctly. When running the areplicate status command it returns the first line in the output file attached to this ticket.

 

However, when I run ps -ef | grep -i rep I see lines 3-7 in the output file attached to this ticket.

 

When everything is working well I would only see the 2 repctl lines. Anytime that I've seen more than just the 2 repctl lines I have had to do a full server rebuild to get a functioning replicate instance. I feel like there is something I'm missing, but I haven't been able to find enough information to continue troubleshooting this.
1 Solution

Accepted Solutions
KellyHobson
Support
Support

Hey @kyhutch_mdb ,

From your steps listed above, can you try stopping the service with this command instead:

/opt/attunity/replicate/bin/areplicate stop

We do not advise customers to stop/start the service with systemctl commands.

Additional doc for reference.

Let us know if you are still experiencing the issues with start up. 

Best,

Kelly 

View solution in original post

15 Replies
Dana_Baldwin
Support
Support

Hi @kyhutch_mdb 

Is this a consistent error, where the Replicate installation only works until you reboot the server, then has to be reinstalled? Have you always had this issue on this server, or is this something new? If so, when did it start, and were there any changes to Replicate/Server/Source/Target when it started?

Thanks,

Dana

kyhutch_mdb
Partner - Contributor
Partner - Contributor
Author

@Dana_Baldwin Thank you for the quick response. This has been a consistent error for me. I have only recently started to test out the product and have run into this a few times. I was hoping it was a user error issue (it still may be) but I need help figuring out what the cause is.

Sadly I've had this issue on multiple servers. I'm using virtualized servers, so it's easy to create new ones. As far as the steps to replicate go.

  1. I install and set up Qlik replicate and am able to use it
  2. I use systemctl stop areplicate to stop the service
  3. I shutdown the server for at least a couple hours
  4. I bring the server back online

That's when I run into the scenario where the service doesn't start up correctly/completely and I see the call to /bin/bash ./rependctl.sh and a java process sitting in the ps -ef output.

kyhutch_mdb
Partner - Contributor
Partner - Contributor
Author

I realized I've left out some crucial information. I have installed the software on CentOS7 and am using Qlik Replicate version 2022.05.0-499.

kyhutch_mdb
Partner - Contributor
Partner - Contributor
Author

Is there a way to check the status of the web console besides running the areplicate status command?

KellyHobson
Support
Support

Hey @kyhutch_mdb ,

From your steps listed above, can you try stopping the service with this command instead:

/opt/attunity/replicate/bin/areplicate stop

We do not advise customers to stop/start the service with systemctl commands.

Additional doc for reference.

Let us know if you are still experiencing the issues with start up. 

Best,

Kelly 

kyhutch_mdb
Partner - Contributor
Partner - Contributor
Author

@KellyHobson

Thank you so much, that fixed it.

Do you recommend that I disable the areplicate service? If so, how can I make sure that the Replicate program auto-starts when the server boots up?

Heinvandenheuvel
Specialist
Specialist

No, you should not disable the service. The service is 'the program' the service spawns tasks as needed. The tasks are independent programs 'under' the service.

fwiw,

Hein

KellyHobson
Support
Support

Hey @kyhutch_mdb ,

Great! Glad to hear.  Agree with @Heinvandenheuvel , I would not disable the service.

Do you have an areplicate listing under /etc/init.d/?

Kelly 

kyhutch_mdb
Partner - Contributor
Partner - Contributor
Author

Yes, there is an areplicate in /etc/init.d/. I did a standard install of the RPM, so that was created as part of it.

To be clear, when I said disable the service I meant run a systemctl disable areplicate, since this didn't seem to start up correctly. That way I would just run the /opt/attunity/replicate/bin/areplicate start|stop command to get the service to start properly, since the systemctl start seems to cause issues.