Unlock a world of possibilities! Login now and discover the exclusive benefits awaiting you.
Tried Changing the data directory location on Windows following below document:
https://help.qlik.com/en-US/replicate/May2023/Content/Replicate/Main/Installation/Change_Data_Direct...
now not able to restart the Qlik Replicate UI server (attached) , while Qlik Replicate server is running fine
New to Qlik, need much help here.
thanks in advance!!
Hi @TNJ ,
Could you please provide us with the following information?
Thanks,
Desmond
Hi Desmond:
Below are the details:
-The original path of the data folder : C:\Program Files\Attunity\Replicate\data
-The new path of the data folder: E:\Attunity\Replicate\data
-The modified registry:
AttunityReplicateConsole --
"C:\Program Files\Attunity\Replicate\bin\RepUiCtl.exe" -d "E:\Attunity\Replicate\data" service run
QlikReplicateServer --
"C:\Program Files\Attunity\Replicate\bin\repctl.exe" -d "E:\Attunity\Replicate\data" service start name=QlikReplicateServer address=127.0.0.1 port=3550
-Qlik Replicate version = V2023.11.0.282
Thanks
TJ
Also, while upgrading the repository, using below command eg:
RepUiCtl.exe repository upgrade --repository "C:\Program Files\Attunity\Replicate\data\GlobalRepo.sqlite"
Getting the error:
C:\Program Files\Attunity\Replicate\bin>RepUiCtl.exe repository upgrade --repository "C:\Program Files\Attunity\Replicate\data\GlobalRepo.sqlite"
Failed to load program components.
Unhandled Exception: System.TypeInitializationException: The type initializer for 'Attunity.Infrastructure.Globals.LogUtil' threw an exception. ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
at Attunity.Infrastructure.Globals.LogUtil..cctor()
--- End of inner exception stack trace ---
Hi @TNJ ,
I've installed the same version, and it worked fine in my environment. I compared your registry, and everything appears to be fine. I would suggest the following:
E:\Atutnity\Replicate\data, ensure that the owner and permissions are the same as those of the original data folder.repcuictl.log. If issue persists, please create a support ticket.
Regards,
Desmond
Dear Desmond
We are facing same issue with Qlik replicate UI service and Qlik compose