Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
Not applicable

Can't change AUTO number setting

I have a calculated field that I would like to display as Gross Margin %. When I go to the Measures editor, the only option that appears is "Auto". (i.e. when I click the arrow, no additional options are shown) I don't have the ability to set the field display, as the other threads I've searched suggest I should.

Is there some kind of "global" setting I need to change in order to activate the display options, in the .ini file, or somewhere? I've tried looking through the app but didn't see any options that would appear to govern this.

thanks,

Kevin

AUTO number.PNG

6 Replies

Re: Can't change AUTO number setting

So drop down won't have any other option? May be it would help if you are able to share a sample where you are seeing this issue

Not applicable

Re: Can't change AUTO number setting

No, as I said, no other options appear. Clicking on the drop down arrow just reverse highlights "Auto", and then goes back to the screen shot I showed earlier when I release the mouse.

rittermd
Honored Contributor

Re: Can't change AUTO number setting

What type of object is this?

What is the full expression?

Not applicable

Re: Can't change AUTO number setting

It's a pivot table. The expression is (ItemExtendedPrice-ItemCost)/ItemExtendedPrice.

When I look at the tutorials, they all suggest I should click the arrow next to "Auto", and I will see a bunch of different formatting options. However, as I said, nothing happens when I click the "Auto" expansion.

lakshmikandh
Valued Contributor II

Re: Can't change AUTO number setting

Hi,

Can you try removing your expression and just leave it as empty and check if that Auto option combo is working ?

Thanks,

Lakshmikandh

Not applicable

Re: Can't change AUTO number setting

Today, I closed the entire app and Qlik Sense, and then reopened them. Now, the number option comes up when I select "Auto".

When in doubt, reboot.