Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Can't open qvf in 3.1 SR2

Hi all,

So I got the problem couple of time since I installed the 3.1 SR2 :

I am editing my loading script, I save, then once I reopen my app it only load and load and load. But never actually load the app.

I get no error message, I only see the loading screen (the one with the bubble and circle we are all familiar with)

Am I the only one who get the problem or are there more of us ?

Since this morning I already lost my work twice. Which is pretty irritating.

Is there a way to reopen those "corrupted files".

Thank you in advance.

1 Solution

Accepted Solutions
Highlighted
Specialist III
Specialist III

I think this is why SR3 was released so soon after SR2

I have been using SR3 and it is OK so far

View solution in original post

8 Replies
Highlighted
Contributor
Contributor

I have the same problem as you describe after installing 3.1 SR2.

Have you got any solutions to the problem?

Highlighted
Not applicable

sondre.taranger I did not found the solution.

Fortunately I got few backup to restor my work.

I now do backup before every save.

One thing I noticed the "file corruption" is less likely to happen if my internet speed is high then if it is not.

As you can guess I did not played arround to see if it happened again.

If anyone have an answer let me know.

Highlighted
Not applicable

I too am having problems with SR2. I am doing a repair at the moment, but after I opened an existing app and reloaded the data it doesn't automatically save and if I try to save by clicking save it just never comes back from it. If i try to close the application I get the error that I may corrupt the data. I actually got my work machine to blue screen after one of these.

I may revert to the previous version.

Highlighted
Not applicable

I had to revert to the previous version. I hope my server is OK because I upgraded this too. I am not impressed.

Highlighted
Specialist III
Specialist III

I think this is why SR3 was released so soon after SR2

I have been using SR3 and it is OK so far

View solution in original post

Highlighted
Not applicable

Thanks Robert, I think I will hold off until it calms down a bit. I lost a couple of hours work on this though.

Highlighted
Not applicable

Hi jane.jackman

In the release note they mentionne this issue, I will mark Robert's answer as the correct one.

You can find the realease note here :

http://download.toccato.com.br/Qlik%20Sense%203.1.3%20FR/QlikSense31_SR3ReleaseNotes.pdf

Hope you will note face the problem again.

Highlighted
Not applicable

If anyone ever face this problem again in SR3, as I did, here are few step I found to prevent this from arriving again :

  • Turn off you internet connection : On the desktop version I found this trick to work. I am not sure why. But I noticed the problem was more frequent when I had connections issues. So I tried to turn of my internet connection, and while offline I never had the problem.
  • Check synthetic keys: I found out that I get the problem mostly when I have a synthetic key in my developement model. So while loading a a table for the first time to your script just Qualify * all your script. You can load, and save. Make a copy and try to reload without the qualify. I saw improvement.
  • This only happens while using the dataload editor, so if you use it make some backups.

Still no way to salvage corrupted files.

Hope this was helpful.