Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Not applicable

Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

I installed QlikSenseServer, it runs under https://mycomputername/  (works fine)

I installed Visual Studio 2015 on same machine.

I try to connect Qlik Analytics Plugin to Qlik sense server with:

https://mycomputername/

Logged on user

and

Other credentials

I added "mycomputername" to whitelist in virtual proxy.

Always same result:

Can not connect to that server, check host and/or user information and try again!

Any ideas?

Greets Heiko

16 Replies
Employee
Employee

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

Have you checked that your Qlik Sense server is aware of your user? It could be that active directory has not been configured correctly for your Qlik Sense Server. To check this, go to the QMC (https://mycomputername/qmc/) then click on "Users" under "Manage Content" in the list on the left hand side (or go to https://mycomputername/qmc/users). You should be able to find your user in the list on that page together with its user directory. If it's not there, then you should check out the "User directory connections" under "Manage resources" in the QMC (https://mycomputername/qmc/userdirectoryconnectors).

Hope it helps!

jbj
New Contributor II

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

If you haven't tried it also try connect with the fully qualified host name, e.g. hostname.domain.com.

Not applicable

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

Hello Øystein,

I use the same user as I used, when I accessed the QMC, HUB or DEV-HUB.

This all working well.

Thanks for the suggestion.

Greets Heiko

Not applicable

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

Hello Johan,

it is a local development pc (Windows 8.1) without connection to any domain.

Thanks for your idea.

Greets Heiko

Employee
Employee

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

And I guess you are not using a prefix for your virtual proxy? (You would have to include that in your connection URL in that case.)

Not applicable

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

You are right, I don't use a prefix.

Still don't know, what I else could try.

Greets Heiko

Not applicable

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

Hi,

Could you problem be the ceritficate or  trust? If you set "Allow HTTP" (qmc - proxies - ports) and try to connect with "http://mycomputername" will that do it?

Best regards

Lars-Göran Book

Not applicable

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

Hello Lars-Göran,

just tried it with http, still same problem.

Thank you

Greets

Heiko

Not applicable

Re: Connection VS 2015 Plugin to Qlik Sense Server fails, how to solve?

Hi again,

Could it be your firewall configuration,  are needed ports opened? See Ports overview ‒ Qlik Sense

Can you access the hub via the browser?

Best regards

Lars-Göran Book