Qlik Community

Ask a Question

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
Showing results for 
Search instead for 
Did you mean: 

Custom Property - Should this be applied BEFORE publishing app or AFTER?

Hi guys,

If you could give me some advice here, I would be very appreciated - shall I apply custom property BEFORE publishing my app, or AFTER publishing my app?

For my situation, I use custom property and associated security rules as one of the access controls for my clients. I have a multi-nodes server environment set up. To my best knowledge, I don't think when to apply custom property should matter. However, I tried both BEFORE and AFTER. Interestingly, I got different results. (FYI - the custom property / security rule worked on other published apps before)

I have 2 accounts for testing, one is root admin account, the other is "client" account (Read Only user role). Both accounts are associated with the same custom property. Then I used the same unpublished app for testing:

1. Test1_app: apply custom property first, and then publish

2. Test2_app: publish first, and then apply custom property.

For Test1_app: the root admin account opens it just fine. However, client account gets "No sheets are available" when open the app (As image below)

For Test2_app: the root admin accounts gets "No sheets are available"; while client account opens it just fine...

Client AccountRoot Admin Account
Test1_AppNo sheets are availableOkay
Test2_AppOkayNo sheets are available


From the Audit section, I can see both accounts have read access to the 2 apps.

Did anyone have the similar issue with me? Or if anyone has any insights about what is going on there?

Please let me know if I missed any details there.

Thanks in advance,


Custom property:


Security Rules:



User Access Audit:


2 Replies

Well, I think I might be able to close this question - we restarted our servers this morning. And this issue was fixed by itself. It's magically working now. I tried the same scenario and this issue is no longer existing.

I may guess there were some issues happened when we our multi-nodes sync up on security rules or custom property. I will go back and check if I can find more proofs.


Is someone elke also running into this same issue? Restarting the services doesn't work.