Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

oscmandino
New Contributor II

Failed to open file in write mode

Hi Community. I am having the next problem:

I have a load for about 350.000.000 records generating a 13 GB QVD file.

I'm storing the information as follows:

STORE * FROM Fact into [lib://QVD/Fact.qvd](QVD)

On that code I am getting random results (some times success, some times fails). Every time it fails, I've got the next error message:

Failed to open file in write mode for file F:\QVD\Fact.qvd

Error: Failed to open file in write mode for file F:\QVD\Fact.qvd

Any help will be appreciated!

Thank you in advance

10 Replies

Re: Failed to open file in write mode

Hi Oscar, seems that one process still has the qvd opened, try checking for process that can be reading from that qvd, or scheduled reloads.

Another option is that the permissions of the file doesn't allows the current user to write the file, but in that case it won't be random.

oscmandino
New Contributor II

Re: Failed to open file in write mode

Hi Ruben, Thank you for your answer.

There is no other process using that file.

My Fact.qvd file is used only in one application that reads it, appends some information and then tries to store the information.

That QVD file will be useful only for the next step in the task (it will not run in parallel)

Khan_Mohammed
Honored Contributor II

Re: Failed to open file in write mode

Store script seem to be incorrect...

Use below Store procedure

STORE Fact into  lib://QVD\Fact.qvd;

Khan_Mohammed
Honored Contributor II

Re: Failed to open file in write mode

To load this table after storing use

Fact:

Load *

From.....your stored location

oscmandino
New Contributor II

Re: Failed to open file in write mode

Hi Shahbaz, I missed the ";" at the end on copy-paste but my code works.

Khan_Mohammed
Honored Contributor II

Re: Failed to open file in write mode

Do you have issue with Storing or Reading?

oscmandino
New Contributor II

Re: Failed to open file in write mode

The problem occurs some times when storing.

Khan_Mohammed
Honored Contributor II

Re: Failed to open file in write mode

I have never seen someone using that type of Store script...

Why not try the one I provided and monitor if you have same issues?

oscmandino
New Contributor II

Re: Failed to open file in write mode

You're right, there is an extra "*" in my code just a copy paste problem.

My store sentence works

Community Browser