Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Not applicable

Filter issue in displaying graphs

Hi,

I have created a KPI and a graph on a sheet. Both using the data from same table. There is a date filter also on the sheet.

Can someone please help so that if I select a valuev or values  from the filter, it should effect only the KPIs and the graph should remain same.

The filter is startdate. In KPI, I am doing sum of sales. And, the Graph has Daywise sales.

Thanks,

Rahul

1 Solution

Accepted Solutions
MVP
MVP

Re: Filter issue in displaying graphs

Try

SUM({<SessionCount={1},ReportType={'DAILY'}, startdate = >}(sales))

Double check that field name startdate is spelled correctly according to the field in your data model.

You can also ignore all selections and set the two field filter like

SUM({1<SessionCount={1},ReportType={'DAILY'}>}(sales))

7 Replies
MVP
MVP

Re: Filter issue in displaying graphs

You can use alternate states to achieve this (other approaches also possible),

https://help.qlik.com/en-US/qlikview/12.1/Subsystems/Client/Content/Alternate%20States.htm

Just  create an alternate state in Settings - Document properties and set the filter / list box and the KPI to the alternate state in general tab of the chart objects.

MVP
MVP

Re: Filter issue in displaying graphs

Alternatively, use set analysis in the graph chart to ignore the filter field selections:

For example, if your dimension is Date and you are using an expression like

=Sum(SalesField)

then add a set expression to ignore the filter selection in field startdate:

=Sum({<startdate= >} SalesField)

Not applicable

Re: Filter issue in displaying graphs

Hi Stefan,

Thanks so much for the response.

I think Alternate state setting can be done in Qlik View. While, I have created KPI and graph in Qlik sense.

Also, wrt your second solution. I am alreay using set analysis in the graph.

SUM({<SessionCount={1},ReportType={'DAILY'}>}(sales))

This is not working when I am selecting a value from the filter.

Need your help.

MVP
MVP

Re: Filter issue in displaying graphs

Sorry, I missed that you are using QlikSense.

Not sure why the second approach is not working, which field are you using in your filter and how have you tried to ignore it in your set expression?

Could you maybe upload a small sample QVF?

Not applicable

Re: Filter issue in displaying graphs

Hi Stefan,

In  filter, KPI and Graph, it is the same startdate field I am using.

In graph, start date is used as dimension.

Please clarify that using the above set analysis shared by me, apart from other filters I am already using i.e., reporttypr and sessioncount, how can I add startdate in that and can avoid startdate filter for the graph.

Thanks,

Rahul

MVP
MVP

Re: Filter issue in displaying graphs

Try

SUM({<SessionCount={1},ReportType={'DAILY'}, startdate = >}(sales))

Double check that field name startdate is spelled correctly according to the field in your data model.

You can also ignore all selections and set the two field filter like

SUM({1<SessionCount={1},ReportType={'DAILY'}>}(sales))

Not applicable

Re: Filter issue in displaying graphs

Thanks very very much Stefan. The issue is resolved.

Can you please resolve one more issue??

Thanks,

Rahul

Community Browser