Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

MVP
MVP

GEO TABLES

Hi everyone,

this is a very strange problem and it smells like a bug, but I'd like to describe it here and possibly get some input from the community.

So, I developed an app in Qlik Sense Desktop. I loaded my data using the Data Manager, and I got the automated Geo tables added for my Countries and Cities. Nice! The data connection was pointing to "__GEO_TABLES" that appears to be hidden from view, but worked never the less...

Then, I uploaded the same app to my Sense Server. Tried to reload the same script, and I got an error stating the file can't be found within the connection "__GEO_TABLES" ...


Next, I tried loading the same data table on the Server, using the Data Manager. The geo coding was added again, and this time the connection was called AttachedFiles. This connection is not hidden, however when you open it, it doesn't appear to hold any data files.


So, I replaced the connection name "__GEO_TABLES" with "AttachedFiles". No luck.


Suspecting that I maybe misspelled the name somehow, I copied the two load statements from the new auto-generated script to my own existing script, and I ran the script again. No luck, same problem.


So, now I have a script generated by the Data Manager, which is running just fine, and a cloned copy of the same script, inserted into my own app, which returns an error. At this point, I'm out of any rational explanations of the reasons for such bizarre behavior.


Any ideas from the community would be appreciated.


thank you!

Oleg Troyansky

http://naturalsynergies.com

http://masterssummit.com

1 Reply
cristian_ionesc
New Contributor

Re: GEO TABLES

Hi, Oleg

I have the exact same problem that you mentioned - when the server is running the loading script it cannot find them like it did on Desktop:

Here is a transcript from the loading log:

"

2018-10-18 13:25:53 0048 LOAD

2018-10-18 13:25:53 0049  Alias AS [__Country],

2018-10-18 13:25:53 0050  ISO3Code AS [__ISO3Code]

2018-10-18 13:25:53 0051 FROM [lib://__GEO_TABLES/countryAliases.qvd]

2018-10-18 13:25:53 0052 (qvd)

2018-10-18 13:25:53      Error: Cannot open file: 'lib://__GEO_TABLES/countryAliases.qvd'

2018-10-18 13:25:53      Execution Failed

2018-10-18 13:25:53      Execution finished."

Did you manage to solve this?

Cristian