Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Highlighted
megabyte23
New Contributor III

Governance Dashboard: General Script Error

We get an error every day from the Governance Dashboard which was installed on our QlikView server by a vendor. I'm not allowed to modify the code, but I can look at it, so here is what I've found from troubleshooting:

1. The error from the log:

2018-11-29 01:00:14 0000 Gathering QVW Metadata
2018-11-29 01:00:14 0001
2018-11-29 01:00:14 0000 Searching for QVGD_SOE_2.0.2.qvd
2018-11-29 01:00:14 0001
2018-11-29 01:00:14 General Script Error
2018-11-29 01:00:14 Execution Failed
2018-11-29 01:00:14 Execution finished.

2. The Load Script Code

In looking at the load script for "Gathering QVW Metadata", I discovered it is happening when it calls the sub "loadQVD" for "QVGD_SOE_2.0.2.qvd".

3. The QVD

QVGD_SOE_2.0.2.qvd exists in the correct file path and I loaded it and I see nothing wrong with it. I thought maybe there would be an extraneous eof character or something throwing it off, but no.

4. Back to the Load Script

Since the log ended, it seems the error must be happening in the attached code. I copied just the code and the QVD to my local machine and it runs fine.

5. Next Steps

I'm at a loss of what to try next since I'm not allowed to modify the code. Our vendor says they cannot work on it as it is a "Training Issue". I'm open to any/all suggestions on what to look for. Thanks for your help.

2 Replies

Re: Governance Dashboard: General Script Error

Right now you have commented out the TRACE after baseFileSize variable, but I would say that add a TRACE statement after every line in your code and see where exactly is it choking.

Also, you might be able to access the folder from your desktop where the qvd is stored, but have you checked if the server have the permissions to go into the location where the qvd is stored?

megabyte23
New Contributor III

Re: Governance Dashboard: General Script Error

I solved this problem - it was caused by a stray "End of Text" character (hex 0x03) in the load script of one of the QVWs on the server that the Governance board reads. It was difficult to find the character, so I'll detail how I did it in case it helps someone else.

1. The error started on 9/7/2018.

2. I looked at folder dates and saw that we put 3 new apps on the server on 9/6/2018.

3. Narrowed it down to one of the apps.

4. Opened the XML for that .QVW and saw that it was corrupted. (From the load script, clicked "Table Files" -> choose the QVW -> "Next" -> Select radio button for "XML")

5. I then went back into the load script and loaded pieces at a time until I produced the XML error.

6. I removed this and now my Governance Dashboard QVW is running great again.

 

Other Note: This post was moved to the "Qlik Sense" area. I tagged it with "Qlik View" on purpose because it's in Qlik View.