Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Not applicable

Iframe selection issues

HI there I have recently tried to use an I frame to embed an object from a qlik app onto a web page that I'm currently working on but have run across an issue I don't know the answer to.

<iframe src='http://10.10.200.227:8080/single?appid=3b60f2dc-7515-49e2-b8a8-924e595a449a&obj=dKQYUJ&opt=nointerac...' frameborder='0'></iframe>

If i just pull the url out of this link and drop it into a new window it takes me to the app at full screen as I expect it would but does something funny I'm not expecting.  It seems to ignore the "BatchDate,12/2/2015" selection I'm trying to make.  If I have the app open from the server in another window with a selection for the date already made and try to load the page I can actually see it clear out the selections that have been made in the app.

Is there something special that needs to be done for dates to be present in the url?

1 Solution

Accepted Solutions
Not applicable

Re: Iframe selection issues

Well it seems we've ran out of time to figure out why this iframe isn't working correctly for me on this one field.  So I've just modified the load script to only bring in data for the current day which is what i was trying to do with the selection filter.  Now the iframe only has the data I want but its not the solution I want.  Thank you guys for the attempts at helping.

4 Replies
philip_doyne
Contributor II

Re: Iframe selection issues

Hi Philip.

We have had issues with iFrames – make sure you are on the latest version of Qlik Sense – and try it on both release streams.  Also check that the format of your date is the same.  Dates are duals and they are stored as both 40500.123 where that is the number of days since 1/1/1900 and also as the alternative e.g. Formatted 01/01/2015 or 1:1:15  so make sure your select string matches the format you are using as the default for your date field in the app.  I am not sure how this differs in Sense from QlikView but this is a common question in Qlik.

reddys310
Honored Contributor II

Re: Iframe selection issues

Hi Philip,

Try this:

<iframe src="https://<ServerName>/single/?appid=ccc53d3a-77c2-48a4-9f5a-f7aa84d82f19&obj=hRZaKk&select=clearall&select=Year,2012" frameborder="0"></iframe>


first try clearing all the filters and then  try applying your filter.



Thanks,

Sangram.

Not applicable

Re: Iframe selection issues

Thank you both for your responses,  I've gone in and made sure to add the clear all and I can see the app flicker ever time the page loads because of that clear all now but the problem isn't resolved for this one field.  Last night I even went so far as to remove all formatting from the date field so that it was purely numbers with no symbols and that didn't work.  For some reason it's only this one field, all others I try affect the app and cause the data to load correctly, I'm going to investigate more and see if i can't figure out a reason why.

Not applicable

Re: Iframe selection issues

Well it seems we've ran out of time to figure out why this iframe isn't working correctly for me on this one field.  So I've just modified the load script to only bring in data for the current day which is what i was trying to do with the selection filter.  Now the iframe only has the data I want but its not the solution I want.  Thank you guys for the attempts at helping.

Community Browser