Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
spividori
Valued Contributor

Legacy mode not working

Hi.

I need to get the coordinates of Google Maps in my application. when executing the recharge, the following error occurs:

This statement only works with lib:// paths in this script mode

El error se ha producido aquí:

GoogleMaps: LOAD @1, @2, num#([result/geometry/location/lat], '#.##', '.', ',') as latitude, num#([result/geometry/location/lng], '#.##', '.', ',') as longitude, "result/geometry/location/lat", "result/geometry/location/lng", [result/geometry/location_type] as location_type, now() as Quand, 'rosario, santa fe, Argentina' as FullAddress, 1 as Top FROM [http://maps.googleapis.com/maps/api/geocode/xml?address=rosario, santa fe, Argentina&sensor=false] (XmlSimple, Table is [GeocodeResponse])

My file Settings.ini:

StandardReload=0

[Settings 7]

What is the problem that throws me this error?

Regards.

1 Solution

Accepted Solutions
thomaslg_wq
Contributor III

Re: Legacy mode not working

3 Replies
thomaslg_wq
Contributor III

Re: Legacy mode not working

thomaslg_wq
Contributor III

Re: Legacy mode not working

The part with "Webfiles and URL" :

"The URL set in the web file data connection is static by default, but you can override the URL with the format specification setting URL is. This is useful if you need to load data from dynamically created URLs."

Loading files from web resources

You can load files from web resources, such as FTP, HTTP or HTTPS, with a web file data connection. The file can be of any type supported by Qlik Sense. You need to make the following settings to the data connection.

SettingDescription
URL

Full URL to the web file you want to connect to, including the protocol identifier.

Example: http://unstats.un.org/unsd/demographic/products/socind/Dec.%202012/1a.xls

If you connect to an FTP file you may need to use special characters, for example : or @, in the user name and password part of the URL. In this case you need to replace special characters with a percent character and the ASCII hexadecimal code of the character. For example, you should replace : with '%3a', and @ with '%40'.

NameName of the data connection.

The URL set in the web file data connection is static by default, but you can override the URL with the format specification setting URL is. This is useful if you need to load data from dynamically created URLs.

See: URL is

spividori
Valued Contributor

Re: Legacy mode not working

Works!

Regards.