Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Make your voice heard! Participate in the 2020 Wisdom of Crowds® Survey. BEGIN SURVEY
MVP
MVP

Legend does not show on one client PC

Hi all,

I've created a Qlik Sense (September 2018 release) sheet with three line charts and two filter panes.

The line charts have 2 dimensions, time on the x-axis and multiple lines grouped by item property and one expressions.

I've activated automatic mode for the legend and it shows just fine (legend to the right) - on my computer.

But on a different client PC, using the same resolution, the legend just does not show up.

I assume that the issue is caused by the responsiveness of Qlik Sense's design, since I also see the legend disappear if I reduce the QS desktop window height some 10 pixel.

What I don't understand though is that the legend disappears if I reduce the height, and the legend shows on the right side of the chart and there is plenty of room for the legend (the line chart area is higher than the legend).

Just for interest, can somebody explain why it does show on one PC and does not on another, using the same resolution?

To resolve the issue, is there any setting I can tweak to get the legend to show on all PCs?

I do get the legend if I maximize the chart, but it would really be helpful to see the legend all the time.

How do you handle the legend-disappearing-issue? Is there any best practice for Qlik Sense?

Best

Stefan

1 Reply
Highlighted
ninnartx
Contributor

Re: Legend does not show on one client PC

Hi @swuehl

I'm facing the same issue.

Did you manage to come up with a solution for this issue?