Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Not applicable

MonthYear Displayed as YYYY-MM-DD 00:00:00

Hello All,

I have a graph like so:

Screenshot (50).png

As you can see, MonthYear is displayed as YYYY-MM-DD 00:00:00. Ideally, I'd like it to be displayed as MM-YYYY. How would I do that?


Best,

Alison 

1 Solution

Accepted Solutions
Not applicable

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Hi Sunny,

I have gotten it to work, thank you for mentioning about the continuous axis.


Appearance -> And I unchecked 'Use Continuous Scale'

9 Replies

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

May be use a calculated dimension

Date(MonthYear, 'MM-YYYY')

Not applicable

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Hi Sunny,

Thank you for your suggestion but sadly in remains the same.

kellymcgrady
Contributor

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Do that in the data load editor Date(MonthYear, 'MM-YYYY')

Not applicable

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Hello Kelly,

I have a Master Calendar that looks like so:

Screenshot (51).png

Please tell me where I should put the code

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Are you using Continuous axis?

Not applicable

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Hi Sunny,

Yes, I am

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

I know you can handle this in QlikView, but since I have very limited knowledge of Qlik Sense, I don't really know if this is possible or not.... If you can share the sample, then I can give it a shot.... But if you want to try on your end, look for a way to format the continuous dimension (if at all it is possible)

kellymcgrady
Contributor

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

What is the table that is pictured in the chart above? That table would need to be configured and looking at your calendar you want 'MMM-YYYY' not 'MM-YYYY'.

Not applicable

Re: MonthYear Displayed as YYYY-MM-DD 00:00:00

Hi Sunny,

I have gotten it to work, thank you for mentioning about the continuous axis.


Appearance -> And I unchecked 'Use Continuous Scale'