Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

erik_wetterberg
Honored Contributor

On Demand App: app navigation link 'Invalid'

Hi,

I have got a problem with On Demand app generation: when I open the selection app, everything works OK, and I can generate apps. But when my user opens the same app, the app navigation link comes upp as 'Invalid'.

Both selection app and template app is in the same stream, and the user has full access to it. The user can actually open both the selection app and the template app.

Anybody has any ideas? Something more I should check?

TIA

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
1 Solution

Accepted Solutions
erik_wetterberg
Honored Contributor

Re: On Demand App: app navigation link 'Invalid'

I still don't know how this happened but I managed to solve it:

  • copy the selector app, the copy will be in 'Work' and be unpublished
  • open the copy, app navigation links are invalid
  • remove app navigation link
  • create new navigation link, you cannot reuse the name, because the old one is still there somewhere, though not visible
  • publish the copy

Now works for both me and the user!

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
1 Reply
erik_wetterberg
Honored Contributor

Re: On Demand App: app navigation link 'Invalid'

I still don't know how this happened but I managed to solve it:

  • copy the selector app, the copy will be in 'Work' and be unpublished
  • open the copy, app navigation links are invalid
  • remove app navigation link
  • create new navigation link, you cannot reuse the name, because the old one is still there somewhere, though not visible
  • publish the copy

Now works for both me and the user!

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
Community Browser