Qlik Community

Ask a Question

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Qlik Sense On Demand App

When i try to generate app through the Qlik Sense On Demand App i get the following error. could anyone help me out with this.

Failed to create new request for link <APP ID>:Bad Request-400

2 Replies

Check these Properties;

On-demand apps are generated in the Qlik Sense hub from navigation links that connect selection apps to template apps. The On-demand app service must be enabled to generate on-demand apps. You can create selection and template apps from the Qlik Sense hub, if you have the appropriate access rights. Selection and template apps are published to streams from the Qlik Management Console, which is a part of Qlik Sense. Generated on-demand apps can also be published from the QMC.

To publish an on-demand app that is generated in a Qlik Sense Desktop installation, you must first import it, by using the QMC.

The security rules applied to the app, stream, or user, determine who can access the content and what the user is allowed to do. The app is locked when published. Content can be added to a published app through the Qlik Sense hub in a server deployment, but content that was published with the original app cannot be edited.

Check this link:

https://help.qlik.com/en-US/sense/June2018/Subsystems/ManagementConsole/Content/manage-on-demand-app...

OR

Qlik Sense requires the creation of a domain service account, instead a local user account. As all services were set up with the local user, after creating the domain account, I had to manually change the account, from local to domain, on each Qlik service. This is because the system does allow you to change the service account during the upgrade.

There is a new On-demand service after the upgrade, and for some reason it did not take the new domain service account, and the log folder it creates, did not have access authorization to the domain service account. After some troubleshooting and realizing the issue, I added the domain service account with read and write permission to the log folder. After doing this, all services are running, the error is gone, and Assets panel is now being displayed.

Check this link:

https://community.qlik.com/thread/270411

Contributor II
Contributor II

could you help me out in enabling the on-demand app service and its navigation