Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Qlik Sense Security Rule: resource.description doesn't work?

Hi. I am trying a very simple security rule where I create a "tag" of sorts in the description, but the script doesn't work. If I change the rule to look for a particular object name, it works fine, but as soon as I attempt to reference the description, I get no results. It seems to be an issue with the resource.description reference. Yes, I did ensure that the App has "GM" in the description. I have tried different values in the description but no difference.

I am using Qlik Sense 3.2 SR4. Help would be greatly appreciated.

I have tried the following which produces no results:

((user.group like "*" and resource.description = "GM"))

((user.group like "*" and resource.description like "*GM*"))

Yet, the following produces the expected result:

((user.group like "*" and resource.name like "test*"))

0 Replies