Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Not applicable

Qlik Sense dimensionless table - death spiral

 

In working on a Qlik Sense Table Object I managed to make Qlik Sense spiral into an error that may be unrecoverable.   The sheet is rendered unworkable and any objects on it cannot be recovered. 

 

 

I was creating a table that was intended to be dimensionless.  Creating such a table is actually pretty cumbersome.  I tried to create a variation that summed all of the data into a dimension field. However, this appeared to cause Qlik Sense to spiral into some kind of infinite loop.  It spins 'forever' with a 'Cancel' button in the middle of the table.

 

 

Clicking the 'Cancel' button seemed a good way to escape. Unfortunately, clicking the 'Cancel' button caused a popup that said 'Data update was cancelled' with the only option a button labeled 'Retry'.  Clicking the 'Retry' button brings Qlik Sense back to the spinner with the 'Cancel' button, and the cycle simply repeats.

 

 

Closing the 'sheet' window and re-opening it results in a repeat of the infinite load.  The same is true of closing the app or Qlik Sense altogether and re-opening it.  All objects within the sheet cannot be edited. The entire app is rendered unworkable.

 

 

The sheet becomes a minefield.   Opening it instantly locks up Qlik Sense.  Is there a way to interrupt the attempted load and recover?  Ver 2.2.4 Build:60.release/ms15.

 

2 Replies
gdebeer
New Contributor II

Re: Qlik Sense dimensionless table - death spiral

Have you tried opening the app without data? In the hub, right click on the app and choose "Open without data".

desertdave
New Contributor

Re: Qlik Sense dimensionless table - death spiral

Good suggestion.  Alas!  Opening without data and selecting the errant sheet still causes the infinite 'Cancel->Retry' loop.

Community Browser