Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

alec1982
Valued Contributor II

QlikSense ErrorMode Issue

hi all,

Anyone has an issue with using QlikSense ErrorMode? after I upgraded to 2.2 it doesnt work and i get an error even I set it to:

Set ErrorMode=0;

Let me know..

5 Replies

Re: QlikSense ErrorMode Issue

I have Qlik Sense 2.2

Capture.PNG

And I tried this and it ran

SET ThousandSep=',';

SET DecimalSep='.';

SET MoneyThousandSep=',';

SET MoneyDecimalSep='.';

SET MoneyFormat='$#,##0.00;($#,##0.00)';

SET TimeFormat='h:mm:ss TT';

SET DateFormat='M/D/YYYY';

SET TimestampFormat='M/D/YYYY h:mm:ss[.fff] TT';

SET FirstWeekDay=6;

SET BrokenWeeks=1;

SET ReferenceDay=0;

SET FirstMonthOfYear=1;

SET CollationLocale='en-US';

SET MonthNames='Jan;Feb;Mar;Apr;May;Jun;Jul;Aug;Sep;Oct;Nov;Dec';

SET LongMonthNames='January;February;March;April;May;June;July;August;September;October;November;December';

SET DayNames='Mon;Tue;Wed;Thu;Fri;Sat;Sun';

SET LongDayNames='Monday;Tuesday;Wednesday;Thursday;Friday;Saturday;Sunday';

SET ErrorMode = 0;

Table:

LOAD * INLINE [

Dim, Sales

A, 50

B, 100

];

Resident: // Error portion just to check if it bypass the error or not

LOAD a,

  b

Resident Table;

alec1982
Valued Contributor II

Re: QlikSense ErrorMode Issue

hi Sunny,

I think you are trying the desktop version while the issue is on the server version.. I also upgraded to 2.2.4 and still have the same issue...

Re: QlikSense ErrorMode Issue

That could be it. I am working on the desktop version. My apologize.

Best,

Sunny

alec1982
Valued Contributor II

Re: QlikSense ErrorMode Issue

looks like not many people play with Sense Server..Smiley Happy

pgrenier
Contributor III

Re: QlikSense ErrorMode Issue

I am experiencing the same issue while trying to load a web table that doesn't exist:

real-chart.finance.yahoo.com/table.csv?s=THI.TO&a=03&b=18&c=2014&d=04&e=01&f=2016&g=d&ignore=.csv

Launching the same statement on a stock that exists works fine (replace THI.TO with SLW.TO for example)

I have added the SET ErrorMode = 0; statement before executing the LOAD, but the script still crashes rather than ignoring the error.

Would anyone have any ideas?

Community Browser