Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

ladislavcapo
New Contributor III

Scrip line error QlikSenseEnterprise 2.1.1

Hi Altogehter,

Am using Qlik Sense Server 2.1.1 and I enconterd weird error message during debuging which prevents me of reloading an app.

Error message I am getting is  Script line error: : FOR i = 0 to NoOfRows('TMP_Databases') - 1

Lines from the script where error message occured.

---------------------------------------------------------------------------------------------

LIB CONNECT TO 'PohodaDB';

FOR  i=0 to NoOfRows('TMP_Databases') - 1

  SET vDatabase = Peek('Databaza', i, 'TMP_Databases');

  SET vICO = Peek('ICO', i, 'TMP_Databases');

  SET vTable = 'Meny';

  LIB CONNECT TO 'PohodaDB';

  $(vTable):

  SQL SELECT

  $(vICO) as [%ID firma],

  ID as [%ID mena],

  Kod as [Mena]

  FROM sCMeny;

NEXT

---------------------------------------------------------------------------------------------

According to my developer knowledge script looks proper

Did anybodody of you face this problem before and knows how to fix it?

Thanks in advance

LACI

5 Replies

Re: Scrip line error QlikSenseEnterprise 2.1.1

See this blog post: Qlik Sense Legacy mode


talk is cheap, supply exceeds demand
ladislavcapo
New Contributor III

Re: Scrip line error QlikSenseEnterprise 2.1.1

Legacy mode did not help.

Re: Scrip line error QlikSenseEnterprise 2.1.1

Does a table with the name TMP_Databases exist at the time the for loop is executed?


talk is cheap, supply exceeds demand
ladislavcapo
New Contributor III

Re: Scrip line error QlikSenseEnterprise 2.1.1

Yes, of course. I just forgot to mention it. I was thinking that this will be the first question

As I said before, script looks ok for me, there is something in behind what QlikSense cannot process.

Basicaly it is a script from QlikView where everything works well. I just corrected data connections and paths.....

Thanks!

tkendrick20
Valued Contributor

Re: Scrip line error QlikSenseEnterprise 2.1.1

Also having this problem. What did you learn?!?!

Community Browser