Qlik Community

Ask a Question

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Talk to Experts Tuesday, January 26th at 10AM EST: Qlik Sense. REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
MVP & Luminary
MVP & Luminary

Strange Scroll Behaviour in Qlik Sense


I spotted some strange scroll behaviour whilst on a client site.  Rows seemed to be duplicated in a table, even though the values in the dimension were distinct.  The values attached to the duplicated rows were also duplicated, but the total looked fine.  On exporting to Excel, no duplicates existed and all looked well.

Subsequently I have done some testing on Qlik Sense Server, Qlik Sense Desktop and Qlik Cloud (3.0 SR1, 3.0 SR1 and 3.1 IR respectively) and found exactly the same problem.

To replicate this issue you can run this very simple load script to get some data:


  RowNo() as Row



and then, once the data is loaded create a sheet and then a Table object.  Into this drop the only dimension.

Drag the table so that only the first five or six numbers are visible, and then scroll.

Initially the scroll bar seems the right size, but on scrolling down it halves in size and duplicate rows appear.  You can see when the table is sorted the point at which the numbers duplicate here:


Behaviour is not entirely consistent, and can change on a reload or resize of the table.  The point at which the values repeat shifts (here you can see it is at 9, I've seen it at 10 and 7 also).

Does anyone know what is going on here, and whether there is a way to fix it?  mto jgd  I feel very uncomfortable handing over apps where this is happening.


11 Replies


I have tried to replicate this with QlikSense Desktop 3.1 but however much I fiddle with it I cannot replicate the duplication issue.  The scroll bar does change in size but no duplicates appear.

Maybe I just don't have the Midas touch.

Attached is the qvf I have been using.  Can you see if you can break it ?



i just tried to recreate the behavior on this platforms

qlik sense server 3.1

qlik sense desktop 3.1

qlik cloud smb

and in all of those platforms i couldn't recreate the behavior , every thing seems to work fine

MVP & Luminary
MVP & Luminary

Hi Bill,

Just dropped that into my Sense Desktop, and it breaks.

I've tried different browsers, so I guess there is some other component on my machine that is spanning browsers.



MVP & Luminary
MVP & Luminary

Hopefully it doesn't affect too many people then - hopefully just me!

I will try on another machine in a bit...


..... but just tried it with the Chrome Browser via the Web Hub on my local laptop and it only scrolls down to number 8 when it should go down to 10.

Then if I add a Filter Pane on the field it then goes down to 9 in the Table, whilst the Filter pane goes down to 10.

And if a select a value and then deselect it, then all is ok.

BUT.......  when I repeated this the table only went down to 6 initially, so as you said it is not inconsistent.

Although I have not managed to see any duplicates yet though.

Sound like one for Qlik Support.  They enjoy the infamous random intermittents.

Not applicable

FYI, I've posted on the same issue (Scrolling bug).  The report include a reproducable (for me) case.

Not applicable

Hi Steve,

I am also facing a similar issue.  And this happens randomly and seems to be related to scrolling.


Hi All,

I have a customer who just reported similar bug. He is using a "touch device".

This bug (same behavior on touch device) was reported to Qlik R&D and is already fix. A solution is expected in coming release.



Hey Steve,

did you find any solution?

A customer is facing the same issue on QS 3.2.3...